Sign in to follow this  
Followers 0
richb

how to set Safari NOT to use Adobe to view PDF's

7 posts in this topic

I just installed Leopard and ran all the updates. When I try to open a PDF it uses Adobe 8.1 instead of just opening up in Safari. I removed 8.1, and then it wouldn't open pdf's at all, just a black screen. Somehow my browser seems to be set on using Adobe instead of it's built-in viewer, or Preview. I can't figure out how to undo this and get it back to using it's own features. I don't see any setting in preferences, etc.

Thanks for your help.

Rich

0

Share this post


Link to post
Share on other sites
I just installed Leopard and ran all the updates. When I try to open a PDF it uses Adobe 8.1 instead of just opening up in Safari. I removed 8.1, and then it wouldn't open pdf's at all, just a black screen. Somehow my browser seems to be set on using Adobe instead of it's built-in viewer, or Preview. I can't figure out how to undo this and get it back to using it's own features. I don't see any setting in preferences, etc.

Thanks for your help.

Rich

Right click on any .pdf and select get info, then inside the get info window choose your preferred application from the "open with" selection.

 

Hope this helps ya

0

Share this post


Link to post
Share on other sites
I just installed Leopard and ran all the updates. When I try to open a PDF it uses Adobe 8.1 instead of just opening up in Safari. I removed 8.1, and then it wouldn't open pdf's at all, just a black screen. Somehow my browser seems to be set on using Adobe instead of it's built-in viewer, or Preview. I can't figure out how to undo this and get it back to using it's own features. I don't see any setting in preferences, etc.

Thanks for your help.

Rich

 

This is a bit of a convoluted way, but it's the only way I know how. Hopefully someone else will have a different option for you. I say, download this free program called TinkerTool which I really like. Once you run TinkerTool, click on the "Safari" tab and make sure the "Disable natif support for display of PDF documents" is not checked.

 

You may also want to check and make sure that you remove the Adobe Safari plugin. There also may be settings in the Adobe software preferences as well, so you may want to check there. Hope this helps.

0

Share this post


Link to post
Share on other sites

"You may also want to check and make sure that you remove the Adobe Safari plugin. There also may be settings in the Adobe software preferences as well, so you may want to check there. Hope this helps."

 

Thanks for the suggestions. I will check out Tinker. How do I remove a plug-in? I seached in Safari help for info on this and found nothing. Thanks again.

 

0

Share this post


Link to post
Share on other sites
"You may also want to check and make sure that you remove the Adobe Safari plugin. There also may be settings in the Adobe software preferences as well, so you may want to check there. Hope this helps."

 

Thanks for the suggestions. I will check out Tinker. How do I remove a plug-in? I seached in Safari help for info on this and found nothing. Thanks again.

 

I would invest in a great app called AppZapper it takes care of all your unwanted Apps and plugins by searching for related plist and files, I and the community swear by it ;-)

0

Share this post


Link to post
Share on other sites

or.....navigate to /Library/Internet Plug-Ins/ and remove the following file: AdobePDFViewer.plugin

 

Sorry should have mentioned this above but was called away.

0

Share this post


Link to post
Share on other sites

I've had this problem before. I suggest you install Adobe Reader. In the preferences of Adobe Reader, then under Internet, you will see "Display PDF in browser using". Uncheck that completely. Quit Adobe Reader and Safari. Then restart Safari. Safari should now use itself to view PDFs. Then you can uninstall Adobe Reader.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0