Jump to content
~Numb~

connecting a pc and a mac via ethernet cable (how to?) or wirelessly via RDC (how to?)

Recommended Posts

Hi all,

I'm a newbie in the world of networking for mac... Currently i'm facing a problem...

I've a iBook G4 1.2GHz and a window laptop running Windows XP media center edition.

both of them are connected to the internet via a Netgear router wirelessly.

My problem is i need to transfer large files to and fro both laptops. and using a portable hardisk to do it is so so so troublesome. :(

Thus i'm exploring the option of connecting both if them via a ethernet cable and do direct networking.

But i have totally no idea how to go about doing it.

Could any kind soul out there give me a step by step tutorial on do it???

 

Another option i read about is via Microsoft's Remote Desktop Connection Client for Mac.

So how does this option work???

Is it easier then the wired solution above??

Anybody have any experience on it?

Could you teach me (step by step too) how to do it too??? :P

 

Thanks for your time...

Share this post


Link to post
Share on other sites

If your Netgear wireless router has Ethernet ports in the back, you can plug both computers in and they will be in the same network. I imagine direct Ethernet cable works, as long as:

  1. You use a cross-over cable to connect them. I do not think regular cable works
  2. You manually configure the IP address on both computers. For example, the OS X computer can be 10.0.0.1 and the XP computer can be 10.0.0.2

Share this post


Link to post
Share on other sites
If your Netgear wireless router has Ethernet ports in the back, you can plug both computers in and they will be in the same network. I imagine direct Ethernet cable works, as long as:
  1. You use a cross-over cable to connect them. I do not think regular cable works
  2. You manually configure the IP address on both computers. For example, the OS X computer can be 10.0.0.1 and the XP computer can be 10.0.0.2

 

Can't do the direct Ethernet cable method, cos the router is in the living room, while both laptops are in my room..

Share this post


Link to post
Share on other sites

Hey ~Numb~, I'm afraid this won't be very thorough, especially since I don't have an XP computer in front of me, but I'll do my best.

 

I've got an iBook G4 myself, and as I understand it, you don't need a crossover ethernet cable—a normal one will be fine—because the iBook ethernet port can adapt itself. So on that front, you should just be able to hook up the cable to each and be laughing.

 

As Haivu says, it may be necessary to assign a manual IP address to each (normally these would be assigned by the router), but you may like to just try it first leaving this alone.

 

The next step is probably to ensure that the files you want to transfer are available for sharing. On XP, I think you do this by right-clicking on the folder you want to share, and select "Security and Sharing…" or something similar.

 

On the iBook, open System Preferences, and go to the Sharing pane. Enable Windows Sharing from the list, and then enable the account you want to share the files from using the button which appears.

 

Then connect to the shares! On the iBook, make the Finder active, then select "Network" from the Go menu. Wait a bit (for some reason it always seems to take a while with me anyway) and if your PC appears, double click to connect. You may be presented with a box asking you to choose a share; select the one for the folder you want to access on the PC. If that has all worked, you should be away.

 

If it hasn't, then select "Connect to Server…" from the Go menu instead. In the "Server Address:" box type (without quotation marks), "smb://IPAddress/", where IPAddress is the IP address (cunningly enough) of your PC. I'm afraid I can't enlighten as to how this might be found. If you have managed to find it, click connect and you should get the shares box as before.

 

To connect on the PC, go to Network Neighbourhood and see if the iBook appears. If not, I think you have to click on something in the bar on the left-hand side—new connection? Then type you iBook's IP address (find it in the Network pane on System Preferences, under the TCP/IP tab for the Ethernet connection), and you should be presented with a prompt for authentication. Type the username and password of the account you enabled previously; you'll get access to all the files for that account.

 

I remember having a really useful step-by-step PDF guide for this when I first got my iBook. Of course I can't find it now! For more info, this site or this one might be useful.

 

Hope that helps, please post back with any further questions/clarifications.

 

Yours,

 

W.

Share this post


Link to post
Share on other sites
To follow up, this page from iFelix provides a very thorough step-by-step guide.

 

Yours,

 

W.

 

I followed the guide, but i'm unable to mount anything...

neither am i able to get anything connected...

Why?

Share this post


Link to post
Share on other sites
If I might ask, how far through did you get?

 

okay here's what i did...

1. i went to my mac's system preferences, inside Sharing, i enabled Personal File Sharing and Windows sharing and Enable my home a/c for to be used as Windows sharing.

2. i click on "About this mac", click on "More Info...", Under the network tab, saw that my IPv4 address was 192.XXX.X.X

so i quickly jotted it down.

3. Over at my pc side, i typed "ipconfig" at the command prompt and got my ip address too, same thing i jotted it down. and enable a folder for sharing in my C drive root directory

4. turn off both machines firewall.

5. However i do have the Zonelabs Alarm running on my PC, could it be the cause of the problem???

6. At Finder, hit Apple+k, dialog window pops up, keyed in smb://192.XXX.X.X (IP address of my PC), click on "Connect"

the progress bar will run and run, and gives me a message " The finder cannot complete the operation because some data in "smb//192.XXX.X.X (IP address of my PC) cannot be read or written (Error code -36)

 

Did i miss out anything?? Both machines are surfin the Net wirelessly via my Netgear router.

Share this post


Link to post
Share on other sites

Hmm.

 

Not massively sure what to suggest. Perhaps check the log of the Zonelabs Alarm for times when it might have blocked your Mac's IP Address; else just create an exception for that IP Address. As far as I can make out, the error you're getting suggests that it just can't find the PC at all (I tried to connect to a PC here that I know is switched off and got that message—quite a stupid experiment!), so that might be something to try.

 

Good luck! Sorry this has been such a trial so far.

 

Yours,

 

W.

 

P.S. This is a long shot, but just in case, perhaps try typing the url "smb://192.XXX.XX.X/", including the last forward slash. [Edit: just tried it; doesn't do anything]

Edited by Walafrid

Share this post


Link to post
Share on other sites

It probably is zonealarm. Its the bane of my life when I'm setting up any network (windows only and mixed platform). Put the entire 192.168.whatever range in the trusted zone.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing

    No registered users viewing this page.

  • Who's Online (See full list)

    There are no registered users currently online

×