Jump to content
Sign in to follow this  
agerom

SUBTITLES +AVI

Recommended Posts

Hi mac users. I have an .avi and .srt subtitle file. Can anyone tell me how to combine one of those and under which aplication in order to burn a movie with subtitles?

 

Mac Book Pro 1.83 Ghz, 1024 RAM

Share this post


Link to post
Share on other sites

What do you mean burn? Do you mean burn the subtitles into the AVI (hard-subbing)? or do you mean Burn to a video CD?

 

If you mean hard-subbing then personally, to put subtitles into AVI files I usually just use mencoder and run "mencoder target.avi -sub subfile.srt -ovc xvid -xvidencopts bitrate=900:chroma_opt:vhq=4:bvhq=1:quant_type=mpeg -oac mp3lame -lameopts cbr:preset=192:mode=3 -subpos 95 -ffactor 10 -o newfilename.avi"

FFMpegX can do it too, but sometimes not as reliably though (for me any way). But thats in Filters, make sure the VOB Subtitles box is checked and hit load subs and find your subtitles.

Either way, its a good idea to replace the default stuff in /usr/local/share/mplayer/font/ (the font.desc and other non folder stuff) with stuff from one of the other folders to increase the subtitle size since the default subtitles are pretty small (I use the stuff from the arial-24 folder) and none of the subtitle options in ffmpegX seem to work (could be because I installed mplayer, without the default stuff mplayer creates they might actually work).

 

If you mean to burn them to a VCD or DVD, FFMpegX can do that, but only if you convert the file to an mpeg2 file (which i dont think it does in the free version), But once its an mpeg 2 then go to Tools > Author, select the mpeg file and subtitles, author as DVD and it will output a video_ts folder you can that most burning apps should be able to burn to DVD.

Edited by ithonicfury

Share this post


Link to post
Share on other sites

Ithonicfury:

 

I recently read your reply posted below, and you are very close to answering a question I have been trying to answer for some time. I hope you can help.

 

I have a number of mkv files that I convert using MoKgVm in order to turn them into avi files with hard-subs. However, since mokgvm uses mencodr whenever I try to modify the subtitle text and size it is always overidden to a font size that is too small to be read.

 

Could you tell me how to swap the default font for a new one? I don't know how to find the hidden files you mention, or the procedure for replacing the small font for one a bit larger.

 

Thanks for your help.

 

eflett

 

What do you mean burn? Do you mean burn the subtitles into the AVI (hard-subbing)? or do you mean Burn to a video CD?

 

If you mean hard-subbing then personally, to put subtitles into AVI files I usually just use mencoder and run "mencoder target.avi -sub subfile.srt -ovc xvid -xvidencopts bitrate=900:chroma_opt:vhq=4:bvhq=1:quant_type=mpeg -oac mp3lame -lameopts cbr:preset=192:mode=3 -subpos 95 -ffactor 10 -o newfilename.avi"

FFMpegX can do it too, but sometimes not as reliably though (for me any way). But thats in Filters, make sure the VOB Subtitles box is checked and hit load subs and find your subtitles.

Either way, its a good idea to replace the default stuff in /usr/local/share/mplayer/font/ (the font.desc and other non folder stuff) with stuff from one of the other folders to increase the subtitle size since the default subtitles are pretty small (I use the stuff from the arial-24 folder) and none of the subtitle options in ffmpegX seem to work (could be because I installed mplayer, without the default stuff mplayer creates they might actually work).

 

If you mean to burn them to a VCD or DVD, FFMpegX can do that, but only if you convert the file to an mpeg2 file (which i dont think it does in the free version), But once its an mpeg 2 then go to Tools > Author, select the mpeg file and subtitles, author as DVD and it will output a video_ts folder you can that most burning apps should be able to burn to DVD.

Share this post


Link to post
Share on other sites

I used to use MoKgVm to do mkv to avi with subtitle conversions, but ran into the same problem you were. I dont know where it keeps the default font, (you could maybe check the package contents, right click on the app and then go to Show Package Contents.)

 

But after trying to fight with it, I got fed up and installed mplayer (which installs mencoder) with MacPorts ("sudo port install mplayer" after you install MacPorts and run "sudo port selfupdate -d") and then I usually replace the mencoder executible with the one thats distributed with FFmpegX (since I never really bothered to find out how to change the default building flags to include xvid support, since it builds with macports without it, the mencoder file you would replace is in /opt/local/bin.)

 

That will give you the fonts folder mentioned above. Which in order to get to (and to get to the /opt/local/bin) you can either go to terminal and run "open /usr/local/share/mplayer/font" or in finder click Go -> Go to Folder.

 

And then I use OnMyCommand to run the mencoder command so all I have to do is right click on an mkv file go to the context menu I setup for OnMyCommand and then hit the command I want.

Incase your interested, the code you would put in OMCEdit (the program that you configure OnMyCommand with) is (assuming the audio track you wanted was the second audio track, and the subtitles were the first subtitle track.)

mencoder __OBJ_PATH__ -aid 1 -sid 0 -subpos 95 -ffactor 10 -ovc xvid -xvidencopts bitrate=900:chroma_opt:vhq=4:bvhq=1:quant_type=mpeg -oac mp3lame -lameopts cbr:preset=192:mode=3 -o ~/Movies/__OBJ_NAME_NO_EXTENSION__.avi

If the language you wanted was the first track youd change '-aid 1' to '-aid 0', and if the subtitles were the second subtitle track then youd change -sid 0 to -sid 1 (or change for whatever track the language and subtitles you wanted were on.)

Edited by ithonicfury

Share this post


Link to post
Share on other sites

Ithonicfury:

 

Thanks for such a speedy reply. Though we share (d) a common problem we don't share a common knowledge of computer science and programming. Your instructions, though appreciated, would take me way out of my league. I wish there were a simpler way, but I would need a step by step, no knowledge presumed guide if I were to take on this task! I will see if I can find MacPorts and OnMy Command as a start.

 

I will try emailing the mokgvm person to see if they know where the default font files are for a Mac, since they only gave details for a windows machine. Perhaps in the near future someone will help those of us who like subtitled animie, but can't read mplayer's default micro font, to solve this problem.

 

Cheers,

 

eflett

 

I used to use MoKgVm to do mkv to avi with subtitle conversions, but ran into the same problem you were. I dont know where it keeps the default font, (you could maybe check the package contents, right click on the app and then go to Show Package Contents.)

 

But after trying to fight with it, I got fed up and installed mplayer (which installs mencoder) with MacPorts ("sudo port install mplayer" after you install MacPorts and run "sudo port selfupdate -d") and then I usually replace the mencoder executible with the one thats distributed with FFmpegX (since I never really bothered to find out how to change the default building flags to include xvid support, since it builds with macports without it, the mencoder file you would replace is in /opt/local/bin.)

 

That will give you the fonts folder mentioned above. Which in order to get to (and to get to the /opt/local/bin) you can either go to terminal and run "open /usr/local/share/mplayer/font" or in finder click Go -> Go to Folder.

 

And then I use OnMyCommand to run the mencoder command so all I have to do is right click on an mkv file go to the context menu I setup for OnMyCommand and then hit the command I want.

Incase your interested, the code you would put in OMCEdit (the program that you configure OnMyCommand with) is (assuming the audio track you wanted was the second audio track, and the subtitles were the first subtitle track.)

mencoder __OBJ_PATH__ -aid 1 -sid 0 -subpos 95 -ffactor 10 -ovc xvid -xvidencopts bitrate=900:chroma_opt:vhq=4:bvhq=1:quant_type=mpeg -oac mp3lame -lameopts cbr:preset=192:mode=3 -o ~/Movies/__OBJ_NAME_NO_EXTENSION__.avi

If the language you wanted was the first track youd change '-aid 1' to '-aid 0', and if the subtitles were the second subtitle track then youd change -sid 0 to -sid 1 (or change for whatever track the language and subtitles you wanted were on.)

Share this post


Link to post
Share on other sites

Its actually rather easy (if a little tedious to get set up at first) and doesnt require any programming knowledge (I sure as heck dont have any.)

 

1. Go to http://www.macports.org/install.php and download and install Macports, open Terminal and run "sudo port -v selfupdate"

 

2. In Terminal, type "sudo port install mplayer"

 

3. after its installed, replace the /opt/local/bin/mencoder with the one in here - http://prdownloads.sourceforge.net/mplayer...ies20060307.zip

 

4. replace the files in /usr/local/share/mplayer/font with the ones from one of the other folders in there (I use arial24), just drag the font.desc and other files from that and replace the ones in the font directory. You may need to right click on the font directory and hit 'Get Info' and change the permissions so you have write ability (make sure to apply it to enclosed items.)

 

5. Download and install OnMyCommand - http://free.abracode.com/cmworkshop/on_my_command.html

 

6. Drag OMCEdit from the OnMyCommand dmg to your application folder

 

7. Open OMCEdit, make a new command.

 

8. Name it whatever you want, set the Activation Mode to "File" and in the Command section, copy and paste the code from my other post and save it.

 

9. Right click on an MKV file and go to the OnMyCommand submenu (will be under the More submenu if your on Leopard.) and select your command.

 

10. Wait for it to be done (You'll be able to tell because it would turn into a regular terminal prompt, the close button on the toolbar of the terminal window will change from a circle to an X when you mouse over it.)

 

And hopefully people releasing subs wont feel the need to use crappy mkv or ogm files (the above works on ogm files too, btw) just so they can waste space including the english track which 9 times out of 10 suck anyway.

Share this post


Link to post
Share on other sites

Ithonicfury:

 

Thanks for sticking with me!

 

I am in trouble already. I downloaded Mac Ports for Tiger (I have 10.4.11) and tried to run the first command from Treminal, but keep getting 'command not found'. Actually, I ran the first command and then it asked me for my password. I entered the password I use to login to the computer, but then it cam back 'command not found' and continued to do so, even though it stopped asking me for the password. Perhaps I have been locked out and need to restart. I will see if there is some other password other than the login that I have not used since I got the machine!

 

Again, thanks for walking me through this. I have been converting Lupin movies to watch with my kids and I have about three that I can only find as mkv files. I would like to surprise them with a few more episodes!

 

Best,

 

eflett

 

Its actually rather easy (if a little tedious to get set up at first) and doesnt require any programming knowledge (I sure as heck dont have any.)

 

1. Go to http://www.macports.org/install.php and download and install Macports, open Terminal and run "sudo port -v selfupdate"

 

2. In Terminal, type "sudo port install mplayer"

 

3. after its installed, replace the /opt/local/bin/mencoder with the one in here - http://prdownloads.sourceforge.net/mplayer...ies20060307.zip

 

4. replace the files in /usr/local/share/mplayer/font with the ones from one of the other folders in there (I use arial24), just drag the font.desc and other files from that and replace the ones in the font directory. You may need to right click on the font directory and hit 'Get Info' and change the permissions so you have write ability (make sure to apply it to enclosed items.)

 

5. Download and install OnMyCommand - http://free.abracode.com/cmworkshop/on_my_command.html

 

6. Drag OMCEdit from the OnMyCommand dmg to your application folder

 

7. Open OMCEdit, make a new command.

 

8. Name it whatever you want, set the Activation Mode to "File" and in the Command section, copy and paste the code from my other post and save it.

 

9. Right click on an MKV file and go to the OnMyCommand submenu (will be under the More submenu if your on Leopard.) and select your command.

 

10. Wait for it to be done (You'll be able to tell because it would turn into a regular terminal prompt, the close button on the toolbar of the terminal window will change from a circle to an X when you mouse over it.)

 

And hopefully people releasing subs wont feel the need to use crappy mkv or ogm files (the above works on ogm files too, btw) just so they can waste space including the english track which 9 times out of 10 suck anyway.

Share this post


Link to post
Share on other sites

Oh, something I forgot, which it lists as a requirement for installing MacPorts, is to install Developer Tools.

Put in your OS X Installation CD and go to Install Additional Software, and pick Developer Tools from that. (might be in the Install Bundled Software Only, one, I cant remember)

If you didnt have Developer Tools installed before running the MacPorts installer, then install it and rerun the MacPorts installer.

And if you have a terminal window open when you ran the Macports installer, then you would need to quit terminal and restart it.

Share this post


Link to post
Share on other sites

I installed the XCode Developer Tools that I found on my hard drive, but am still experiencing the same problem. Here is a script:

 

Welcome to Darwin!

Power-Mac-G4:~ eFlett$ "sudo port -v selfupdate"

-bash: sudo port -v selfupdate: command not found

Power-Mac-G4:~ eFlett$ sudo port -v selfupdate

Password:

sudo: port: command not found

Power-Mac-G4:~ eFlett$ sudo port -v selfupdate

sudo: port: command not found

 

What am I missing? I installed the tools, re-installed Macports and closed the Terminal, but still the same problem. I am going to assume that the tools I installed were not from the install discs.

 

You did not think this was going to be such a challenge, did you?

 

Thanks,

 

eflett

 

Oh, something I forgot, which it lists as a requirement for installing MacPorts, is to install Developer Tools.

Put in your OS X Installation CD and go to Install Additional Software, and pick Developer Tools from that. (might be in the Install Bundled Software Only, one, I cant remember)

If you didnt have Developer Tools installed before running the MacPorts installer, then install it and rerun the MacPorts installer.

And if you have a terminal window open when you ran the Macports installer, then you would need to quit terminal and restart it.

Share this post


Link to post
Share on other sites

Did you run the installer (MacPorts-1.5.0.pkg) or just drag what was in the DMG to the applications folder (it actually needs to be installed, unlike most other Mac apps, so its understandable if you didn't.)

If you, did you get any errors during the install process?

 

If you didn't get any errors, try running "sudo /opt/local/bin/port -v selfupdate" (without quotes) and see if that does anything.

Share this post


Link to post
Share on other sites

I ran 'sudo /opt/local/bin/port -v selfupdate', it asked for my password and then it went through a long list of thngs, ending with the following:

 

Downloaded MacPorts base version 1.600

 

The MacPorts installation is not outdated and so was not updated

selfupdate done!

client-2-38:~ eFlett$ sudo port -v selfupdate

sudo: port: command not found

client-2-38:~ eFlett$ sudo port install mplayer

sudo: port: command not found

client-2-38:~ eFlett$

 

Now I am thinking that the problem may be that I am running version 1.6 instead of 1.5.

 

eflett

 

Did you run the installer (MacPorts-1.5.0.pkg) or just drag what was in the DMG to the applications folder (it actually needs to be installed, unlike most other Mac apps, so its understandable if you didn't.)

If you, did you get any errors during the install process?

 

If you didn't get any errors, try running "sudo /opt/local/bin/port -v selfupdate" (without quotes) and see if that does anything.

Share this post


Link to post
Share on other sites

I just tried running the install mplayer command, only with this prefix: "sudo /opt/local/bin/port install mplayer"

 

I ended up with this error message:

client-2-38:~ eFlett$ sudo /opt/local/bin/port install mplayer

---> Fetching jpeg

---> Attempting to fetch jpegsrc.v6b.tar.gz from http://www.ijg.org/files

---> Attempting to fetch droppatch.tar.gz from http://sylvana.net/jpegcrop/

---> Verifying checksum(s) for jpeg

---> Extracting jpeg

---> Applying patches to jpeg

---> Configuring jpeg

Error: Target org.macports.configure returned: configure failure: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_graphics_jpeg/work/jpeg-6b" && ./configure --prefix=/opt/local --enable-shared --enable-static " returned error 1

Command output: checking for gcc... /usr/bin/gcc-4.0

checking whether the C compiler (/usr/bin/gcc-4.0 -O2 -L/opt/local/lib) works... no

configure: error: installation or configuration problem: C compiler cannot create executables.

 

Error: The following dependencies failed to build: jpeg lame ncurses ncursesw libiconv libmad pkgconfig libogg libpng zlib libungif libvorbis lzo2

Error: Status 1 encountered during processing.

client-2-38:~ eFlett$

 

I ran 'sudo /opt/local/bin/port -v selfupdate', it asked for my password and then it went through a long list of thngs, ending with the following:

 

Downloaded MacPorts base version 1.600

 

The MacPorts installation is not outdated and so was not updated

selfupdate done!

client-2-38:~ eFlett$ sudo port -v selfupdate

sudo: port: command not found

client-2-38:~ eFlett$ sudo port install mplayer

sudo: port: command not found

client-2-38:~ eFlett$

 

Now I am thinking that the problem may be that I am running version 1.6 instead of 1.5.

 

eflett

 

Did you run the installer (MacPorts-1.5.0.pkg) or just drag what was in the DMG to the applications folder (it actually needs to be installed, unlike most other Mac apps, so its understandable if you didn't.)

If you, did you get any errors during the install process?

 

If you didn't get any errors, try running "sudo /opt/local/bin/port -v selfupdate" (without quotes) and see if that does anything.

Share this post


Link to post
Share on other sites

Sounds like the first problem is that it wasnt added to your path for some reason.

You could go to terminal and type "cp ~/.profile ~/.profile.old && nano ~/.profile" (without quotes) and then copy and paste the following into it.

#
# Your previous .profile  (if any) is saved as .profile.mpsaved
# Setting the path for MacPorts.
export PATH=/opt/local/bin:/opt/local/sbin:$PATH

##
# DELUXE-USR-LOCAL-BIN-INSERT
# (do not remove this comment)
##
echo $PATH | grep -q -s "/usr/local/bin"
if [ $? -eq 1 ]; then
PATH=$PATH:/usr/local/bin
export PATH
fi

 

Then hit Ctrl+O, and then Ctrl+X.

 

The second problem seems to be that developer tools didnt install the compilers that MacPorts needs, so you may need to rerun the installer for Developer Tools from your Tiger installer DVD.

Share this post


Link to post
Share on other sites

Ithonicfury:

 

I managed to get mplayer installed, after I upgraded my XCode Tools to 2.5.

 

I swapped the mencoder, but am stuck on step #4:

 

4. replace the files in /usr/local/share/mplayer/font with the ones from one of the other folders in there (I use arial24), just drag the font.desc and other files from that and replace the ones in the font directory. You may need to right click on the font directory and hit 'Get Info' and change the permissions so you have write ability (make sure to apply it to enclosed items.)

 

I just can't find the path/folders you have specified. Could you unpack this step in a bit more detail? I find a usr path in my Developer folder, but it does not lead to the mplayer/font folder. Which files am I to replace with which? What are the 'other files' that I am to replace in the font directory?

 

Thanks!

 

eflett

Share this post


Link to post
Share on other sites

Open terminal and type "open /usr/local/share/mplayer/font" (without quotes) and hit enter.

That will open up a finder window to the right folder.

Then right click on the font directory and hit Get Info, on the bottom of the information window in the Ownership & Permissions: part, hit the triangle next to details to get more options. Hit the lock to make it so you can change the permissions, and change it so that their all Read & Write and hit Apply to enclosed items.

 

There will be several directories in the font directory (arial-14 to arial-28) and some files ('font.desc', and some .raw files, a readme and a 'runme'.)

If you click in the arial-24 directory, it will have its own 'font.desc', the .raw files and 'runme' files, just drag those over to the font directory (or copy them which'd probably be a little better) to replace the ones that are in there by default.

Share this post


Link to post
Share on other sites

Well, I'm almost there.

 

I entered the code you advised in the OMCEdit program and then selected the OMCEdit submenu after right-clicking on the MKV file. However, nothing happened. A terminal prompt/box did not open and the file appears to be unaffected. In fact, I can't see the subtitles anymore, although the sound and picture are fine.

 

What I want to do ultimately is burn the Arial 24 subtitles onto the file so I can have it as an avi which I can then edit in my iMovie program. Will the OCMEdit command enable me to produce such a file?

 

Finally, and the despair is setting in, is there any way I can send this file to you to see if the problem is with the file, my computer or both?

 

Again, many thanks for all the tutorials!

 

eflett

Share this post


Link to post
Share on other sites

One more update:

 

It appears to be working. When I open the mkv file in VLC the subs are much larger and easily readable. Now I want to create a file that has these subs embedded in the video file. I am going to try that in MoKgM unless you have a better suggestion. What I need is an avi or mpg4 file that has the video, audio and subs burned on it so I can edit it in iMovie. Is MoKgM the best way to do this?

 

Thanks again,

 

eflett

Share this post


Link to post
Share on other sites

You need to make sure that the code is pointing to the right subtitle file, if you open the file in VLC then go to the Video menu and then to "Subtitle Track". Find out which subtitle track you want and then in OMCEdit, change the script so that the '-sid X' is pointing to the right one.

Subtitle track 1 is -sid 0

Subtitle track 2 is -sid 1

Subtitle track 3 is -sid 2, etc

Share this post


Link to post
Share on other sites

Got it!

 

Now, is there a way to export this to create a hard-subbed avi or mpg4 file?

 

Is putting it through mokgvm the best way to do this? I got the impression that you stopped using that program. If so, how do you go about creating the hard-subbed file?

 

I think this may be my last question...

 

eflett

 

You need to make sure that the code is pointing to the right subtitle file, if you open the file in VLC then go to the Video menu and then to "Subtitle Track". Find out which subtitle track you want and then in OMCEdit, change the script so that the '-sid X' is pointing to the right one.

Subtitle track 1 is -sid 0

Subtitle track 2 is -sid 1

Subtitle track 3 is -sid 2, etc

Share this post


Link to post
Share on other sites

The mencoder script should export it as an avi with the subtitles hard coded in your Movies folder (regardless of where the mkv file is.

If it doesnt then it seems for some reason its not wanting to go. Try changing the Execution Mode of the command in OMCEdit to Terminal and see if that brings up a window when you run it and if it gives you any errors.

 

Although, now that you installed mplayer and replaced the default font file, you could probably run MoKgM to see if maybe it will pick up the new mplayer default font (it uses mencoder at its core I believe, and it should look to the same place for the default font files.)

 

I just use the mencoder script because its quick (once you get it set up) and you can customize the quality settings abit more.

Share this post


Link to post
Share on other sites

I am running it through mokgvm right now, but it is painfully slow.

 

THis is the error message I got when I ran the command by right-clicking on the mkv file:

 

mencoder /Users/eFlett/Desktop/Alcatraz\ Connection\ QT.mkv -aid 1 -sid 2 -subpos 95 -ffactor 10 -ovc xvid -xvidencopts bitrate=900:chroma_opt:vhq=4:bvhq=1:quant_type=mpeg -oac mp3lame -lameopts cbr:preset=192:mode=3 -o ~/Movies/Alcatraz\ Connection\ QT.avi

Last login: Wed Jan 23 12:57:24 on ttyp1

Welcome to Darwin!

client-2-38:~ eFlett$ mencoder /Users/eFlett/Desktop/Alcatraz\ Connection\ QT.mkv -aid 1 -sid 2 -subpos 95 -ffactor 10 -ovc xvid -xvidencopts bitrate=900:chroma_opt:vhq=4:bvhq=1:quant_type=mpeg -oac mp3lame -lameopts cbr:preset=192:mode=3 -o ~/Movies/Alcatraz\ Connection\ QT.avi

-bash: mencoder: command not found

client-2-38:~ eFlett$

 

 

Suggestions?

 

eflett

Share this post


Link to post
Share on other sites

Hmm, for some reason MacPorts didnt do a proper job installing paths, if you put "/opt/local/bin/mencoder" (without quotes) instead of just "mencoder" at the beginning, then it should work.

 

And it will take time (maybe 10mins+ depending on the size of the movie, how fast your computer is etc), in order to burn the subs into the movie, it needs to reencode the video, and thats going to be the case no matter how you go about putting the subs in it.

Share this post


Link to post
Share on other sites

Thanks Ithonicfury!

 

The new font is working with mokgvm and producing a hardsubbed avi file that I can read. I did a one-pass encode, but it still took quite some time.

 

I did another mkv file with mplayer, and it seems to be taking the same amount of time, if not longer. Does the code you sent me conduct a one pass or two pass encode with mplayer?

 

Can I throw you a couple more questions?

 

I have a srt file that I want to modify in TitleLab and then reattach to an mkv file or insert into an avi file (the timing is off on some of the the subs). TitleLab only lets me export to a QuickTime text file or DVD Studio Pro. Is there a way to insert any of these files into a quick time movie (avi, mpg4, etc) after modifying and saving the subs as a Quick Time text file?

 

Finally, some of the mkv files I have have an english dub track attached. I know you think these generally suck, but when my kids have an opportunity to NOT read subs I try to get them the dubbed versions. In that case I will demux the files, attach the dub file to the video file and then import both into iMovie so I can edit them. When I export to an mpg4 some portions of the movie, particularly the white portions where action is taking place, show black cubes and won't render the whites properly. The darker and slower the film portions, the less of a problem with the black cubes there is. I don't know what is happening here to even do a google search to address the problem. Does this problem have a name? A solution?

 

Cheers,

 

eflett

Share this post


Link to post
Share on other sites

The code I use does a one pass encode, but it also uses a few more options to increase the quality (or rather, to not decrease the quality as much), which is why it takes longer then just a standard one pass encode with mokgvm.

 

As for editing the subtitles, Im not sure. I usually dont even bother editing them. The best I can do is say maybe check out Miyu to see if maybe that will work for you.

 

To get the english dub out of MKV files, I think Mokvm can do that (but im not sure since its been so long since Ive used it.) And if you set the video settings to passthrough, then you wont lose any quality and it wont take nearly as long.

 

I usually use this mencoder script with OMC on the MKV for extracting the dub if I want to keep it.

mencoder __OBJ_PATH__ -aid 1 -ovc copy -oac mp3lame -lameopts cbr:preset=192:mode=3 -o ~/Movies/__OBJ_NAME_NO_EXTENSION__.avi

 

The problem with iMovie is it wants to only deal with a specific format that it decides is appropriate, instead of whatever Quicktime will play. Which means that when you import a movie into iMovie, it encodes it, and when you export a movie from iMovie, it encodes it again.

Everytime you encode video or audio, it loses quality, and can show artifacts like the cubes and such you were describing.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing

    No registered users viewing this page.

  • Who's Online (See full list)

    There are no registered users currently online

×