Jump to content
mwfitch

Forcing WIFI

Recommended Posts

I have a successful wifi connection on my home network, but at my office (with wifi network found, and connected) my iPhone prefers the EDGE connection over the wifi. This does not happen at the home network, it will always attempt the wifi first.

Any ideas appreciated. Thanks

Mark

Share this post


Link to post
Share on other sites
I have a successful wifi connection on my home network, but at my office (with wifi network found, and connected) my iPhone prefers the EDGE connection over the wifi. This does not happen at the home network, it will always attempt the wifi first.

Any ideas appreciated. Thanks

Mark

 

After a while, in order to conserve battery, the iPhone will disconnect from the wifi network and use edge. I've noticed this is how my iPhone works anyway... could be an issue with the wifi card on yours though...

Share this post


Link to post
Share on other sites

I have the same problem as you, even when it has a full battery it goes on EDGE as soon as I go on safari or youtube.

Share this post


Link to post
Share on other sites
I have the same problem as you, even when it has a full battery it goes on EDGE as soon as I go on safari or youtube.

 

 

I don't have this problem.

 

Verify your wifi settings are correct. You might have to use text values for the key rather than hex. The phone does not tell you it's having a problem. If it can't connect, it will connect to the next successful thing. Hence the edge connection.

 

Drop the network, then reconfigure. There is a security box right above the password setting for the wep key. Select hex or ascii and enter your key.

Share this post


Link to post
Share on other sites
I don't have this problem.

 

Verify your wifi settings are correct. You might have to use text values for the key rather than hex. The phone does not tell you it's having a problem. If it can't connect, it will connect to the next successful thing. Hence the edge connection.

 

Drop the network, then reconfigure. There is a security box right above the password setting for the wep key. Select hex or ascii and enter your key.

 

My iPhone picks up the access point, authenticates to it, has an IP and subnet, shows full signal strength. It just seems to choose EDGE over it. I take it home where I have another AP and it honors the WIFI first, as expected.

I think I will delete the connection and recreate it just for fun and see if it helps.

Thanks.

Mark

Share this post


Link to post
Share on other sites

My iPhone logs on to my access point, choses edge, and then bitches b/c it "Can't connect to edge" weirdly this doesn't effect safari, just Mail and Google Maps.

Share this post


Link to post
Share on other sites

After some additional testing, my phone will connect successfully w/o any security in place but when the WEP is enabled, it will not authenticate. I can live w/o the 802.11 at work, but it would be handy.

Mark

 

Also, the WEP key entered is accepted, I just cant get the phone to use the wireless network.

Edited by mwfitch

Share this post


Link to post
Share on other sites

well i fixed my wifi problem by typing my pw into the hex and ascII slot not the wep password slot

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing

    No registered users viewing this page.

  • Who's Online (See full list)

    There are no registered users currently online

×