Jump to content
the JoshMeister

SIP voice calls don't work w/ Belkin router

Recommended Posts

I already called Belkin about this, and their tech support rep said someone would call me back within 4 hours. Well, that was roughly 60 hours ago, and I'm still waiting. =)

 

Several months ago, I was able to do voice chat through Gizmo and similar voice chat apps on my MacBook Pro. However, since I upgraded to my Belkin Wireless Pre-N Router, I've had major issues with voice chat. If I try to make a free call using SIP I get broken audio, and by that I mean that big chunks of the conversation are dropped. In particular, I've tried dialing into TalkShoe at sip:123@66.212.134.192, at the same time as other people are called in via SIP and are having no trouble with it at all. Each time I call in, I can hear the recorded voice say (something like) "...oe. ...ease en... cas... followed... po..." In other words, very little audio gets through. If I try to dial the appropriate login numbers and use it anyway, TalkShoe tells me it doesn't understand what I've dialed, meaning (apparently) that the choppiness affects outbound audio transmissions as well. This isn't just a Gizmo problem because I've tried other apps as well with the same results. I haven't changed any hardware on my Mac or my network other than the router.

 

Here's some of what I've done to troubleshoot, to no avail:

 

* Turned off the software firewall on the Mac

* Forwarded ports specific to SIP, Gizmo, etc. from the router to the IP address of the computer I'm using

* Failing the above, I made the Mac's IP a DMZ long enough to try it out again

* Tried playing with QoS settings on the router (which appear to only affect wireless)

* Tried a wired connection (as opposed to wireless) using a known-working Cat5e cable (even though Gizmo used to work fine wirelessly with my old router)

 

Any suggestions? This router is awesome with the one exception that voice chat doesn't want to work with it. =)

 

Thanks in advance for any help anyone can provide.

 

~Josh

Share this post


Link to post
Share on other sites

Hey,

 

Do you have UPnP turned on? I ask because Gizmo, and many other SIP based VoIP services use UPnP to open the RTP streams used to carry voice traffic through your router. Many router manufacturers have taken to disabling UPnP due to several security concerns voices over the past year.

 

You could check to see if UPnP is activated, and if its not pop into the preferences screen and under advanced set Transport Setup to manual. Set the SIP and RTP ports to ports of your choice and set them up for port forwarding on your router.

 

I hope this helps.

Edited by s03bf0c0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing

    No registered users viewing this page.

  • Who's Online (See full list)

    There are no registered users currently online

×