Jump to content
Sign in to follow this  
MacMadMan

I eat Brainz!!!

Recommended Posts

Hey all!

 

I recently switched from a eMac to an intel Mac mini and have been happy with it, with very few exceptions.

One of which is using IeatBrainz. It worked fine on the old tank (eMac) but not on Omnius (mini)

 

I tried at first to migrate everything over and this was the only program that didn't work.

 

Then I made a new user profile on Omnius and is still won't work, the icon will just bounce 3 times and.... NOTHING!

 

I miss that program and really need some help.

 

Heck, I even email the author to no avail.

 

I'm at the end of my rope here, HELP!!!

Share this post


Link to post
Share on other sites
Can you open any other PowerPC apps? Or any universal apps with rosetta?

 

 

Nope, all other PPC apps work fine with no problems whatsoever.

This is the only thing that's choking!!

Edited by MacMadMan

Share this post


Link to post
Share on other sites

I just checked this on my Intel MacBook and it ran perfectly. Have the console open next time you try and launch and see what errors are getting spit out. You can find the console in the Utilities folder inside of the Applications folder in your hard drive. It looks like it's not so much a problem with iEatBrainz as it is with your specific computer.

 

If you used the migration assistant I'd try deleting your preference file from iEatBrainz that may have gotten copied just incase something there is screwing up.

 

Just post the errors from the console and I'll have a look at it and see if I can't figure this out.

 

-Tom

Share this post


Link to post
Share on other sites
I just checked this on my Intel MacBook and it ran perfectly. Have the console open next time you try and launch and see what errors are getting spit out. You can find the console in the Utilities folder inside of the Applications folder in your hard drive. It looks like it's not so much a problem with iEatBrainz as it is with your specific computer.

 

If you used the migration assistant I'd try deleting your preference file from iEatBrainz that may have gotten copied just incase something there is screwing up.

 

Just post the errors from the console and I'll have a look at it and see if I can't figure this out.

 

-Tom

 

First:

I tried fresh reinstalls quite a few times, after deleting all associated files.

 

When I opened console, and then IEB, here's what I got!

===== Wednesday, August 15, 2007 9:00:53 PM US/Central =====

dyld: NSAddImage() error

dyld: no suitable image found. Did find:

/System/Library/Printers/Libraries/libConverter.dylib: mach-o, but wrong architecture /System/Library/Printers/Libraries/libConverter.dylib

 

 

makes NO sense to me!!

Share this post


Link to post
Share on other sites

Alright, I get what it's saying, I'm just not sure why. The NSAddImage() part is your app loading the libraries it needs to run. For some reason your computer is having trouble loading that library. I found a bunch of other people having this error and didn't find any solutions other than doing an archive and install. Everyone seemed to be using some rosetta app on an intel mac, the apps were different for different people. Most of them were using MS Office, I don't know if that's related or if just a lot of people are relying on rosetta for their MS Office.

 

To avoid an archive and install you could try to find the library on your install disk and just replace the one on your HD if the problem is a corrupted library.

 

This project is open source, so if I have the time and energy one of these days I'll try to compile the thing as a universal binary. I don't have any days off this week so it'll be a while before I have the time, but anyone else familiar with SVN stuff could give it a whirl.

 

-Tom

Share this post


Link to post
Share on other sites
Alright, I get what it's saying, I'm just not sure why. The NSAddImage() part is your app loading the libraries it needs to run. For some reason your computer is having trouble loading that library. I found a bunch of other people having this error and didn't find any solutions other than doing an archive and install. Everyone seemed to be using some rosetta app on an intel mac, the apps were different for different people. Most of them were using MS Office, I don't know if that's related or if just a lot of people are relying on rosetta for their MS Office.

 

To avoid an archive and install you could try to find the library on your install disk and just replace the one on your HD if the problem is a corrupted library.

 

This project is open source, so if I have the time and energy one of these days I'll try to compile the thing as a universal binary. I don't have any days off this week so it'll be a while before I have the time, but anyone else familiar with SVN stuff could give it a whirl.

 

-Tom

 

 

By "this project" are you referring to IEB? If so, nice program!

I do not run MS office, don't like it, don't need it.

 

the library to look for is NSAAddimage()? And exactly where should I put it (e.g. the full path!)?

Thanks for your help, it's much appreciated! I've been fighting this for months! Nobody on 2 other forums even addressed it.

 

I'll scour my DVD's for that lib file this weekend, unless somehow it just magically shows up attached to a PM.....

Share this post


Link to post
Share on other sites

I do my best to address everything on this forum that I feel that I have something to add to. I love this community and do my best to keep it what it is, if not better it. I often send people here who have no intention of ever listening to the MacCast just to get Mac help.

 

No, NSAddImage() isn't the library it's the function (a function is basically a routine performed by a program in the course of its execution, for more information learn to program) used to load libraries into memory. The library it's apparently trying to load is the libConverter.dylib library and should be in the /System/Library/Printers/Libraries/ folder as indicated in the error message.

 

I'm not even sure that it is a corrupted library that's the issue, that does seem to be the consensus on other forums though.

 

As for the reference to "This project" yeah I was talking about iEatBrainz. It is open source and I have the source code downloaded on my machine (I know I said I didn't have time, but a bout of insomnia tonight has taken care of my not having time) and I tried to compile it and I got some errors that are totally unrelated to the fact that I am trying to make it universal. It could be a long time for me to sort those out. Perhaps emailing the developer would encourage someone familiar with the code on this app to recompile it for intel.

 

Good luck with all of this technical stuff. It's starting to sound like archive and install might be the easiest way to go, but if you don't want to go through that, you can always try this.

 

-Tom

Share this post


Link to post
Share on other sites
I do my best to address everything on this forum that I feel that I have something to add to. I love this community and do my best to keep it what it is, if not better it. I often send people here who have no intention of ever listening to the MacCast just to get Mac help.

 

No, NSAddImage() isn't the library it's the function (a function is basically a routine performed by a program in the course of its execution, for more information learn to program) used to load libraries into memory. The library it's apparently trying to load is the libConverter.dylib library and should be in the /System/Library/Printers/Libraries/ folder as indicated in the error message.

 

I'm not even sure that it is a corrupted library that's the issue, that does seem to be the consensus on other forums though.

 

As for the reference to "This project" yeah I was talking about iEatBrainz. It is open source and I have the source code downloaded on my machine (I know I said I didn't have time, but a bout of insomnia tonight has taken care of my not having time) and I tried to compile it and I got some errors that are totally unrelated to the fact that I am trying to make it universal. It could be a long time for me to sort those out. Perhaps emailing the developer would encourage someone familiar with the code on this app to recompile it for intel.

 

Good luck with all of this technical stuff. It's starting to sound like archive and install might be the easiest way to go, but if you don't want to go through that, you can always try this.

 

-Tom

 

Excellent!!!

I'll try to find/swap out the library file, that's within my scope of knowledge.

As for a archive & install, I've been VERY lucky running OS X and have never had to do that on this on any of my other machines. I assume it's a "boot to the DVD, and choose an option" type of a project then?

 

If you're taking votes, I vote for making IeatBrainez universal!! It would be mucho appreciated.

Share this post


Link to post
Share on other sites
Excellent!!!

I'll try to find/swap out the library file, that's within my scope of knowledge.

As for a archive & install, I've been VERY lucky running OS X and have never had to do that on this on any of my other machines. I assume it's a "boot to the DVD, and choose an option" type of a project then?

 

If you're taking votes, I vote for making IeatBrainez universal!! It would be mucho appreciated.

 

 

got it nailed!

did a archive & install, and it's much better now.

 

now it's re-downloading all of the OS and security updates, etc...

 

i'll be fully functional soon!!

Share this post


Link to post
Share on other sites

Looks like I spoke too soon!!

It's not working now, and I've figured out why.

 

After doing a archive and instal, I ran monolingual, it gets rid of unused languages, code, etc.

Since running it, IEB isn't working anymore, just like before.

 

I'll run an archive and install again and NOT run monolingual again!

Share this post


Link to post
Share on other sites

Run monlingual to get rid of languages, not architectures.

Share this post


Link to post
Share on other sites
Run monlingual to get rid of languages, not architectures.

 

 

Thanks, I will.

 

I did another archive and restore, and this time it didn't work!! IEB just bounces, and won't open. Any other suggestions before I try it again?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing

    No registered users viewing this page.

  • Who's Online (See full list)

    There are no registered users currently online

×