Jump to content
Brian R

Ethernet works/Airport doesn't

Recommended Posts

2.5 yr switcher with a frustrating problem -- I'm not a networking/wireless geek, so replies in plainspeak appreciated:

 

I had a stable home network running like a dream, but something's changed/been corrupted & I can't figure it out. The only changes I've made have been running Software Update. The symptoms of my problem:

 

- MacBook Pro connects via ethernet at home without a hitch

- connects to my home wireless network -- strong Airport signal

- BUT can't transmit data (browser, e-mail, iTunes) -- pages don't load, e-mail/iTunes don't connect

- I CAN connect wirelessly as before to other networks (work, public)

- my wife's PC continues to connect wirelessly on our home network without problems

 

In short: the problem is only my machine only on my home wireless network; connects but no data transfer.

 

Have already done the usual: rebooted, powered down & reset cable modem & router, repaired permissions, updated firmware on router, reentered WPA Personal security key, all without success. I've compared Network settings to my old PowerBook (which still connects) to sure nothing had been changed, and they appear comparable.

 

It seems there may be a corrupt settings file of some sort on my MacBook, but don't know what/where or the remedy.

 

The enviroment:

- MacBook Pro /OS X 10.4.10

- Comcast ISP / Motorola Surfboard cable modem /LinkSys WRT54GX4 wireless G router with latest firmware update

 

It's a shame having this beautiful notebook machine and being tethered to the desk by an ethernet cable....

Many thanks in advance for all input.

Share this post


Link to post
Share on other sites

After "connecting' to your home wireless, see if you can connect to the Router's admin pages in Safari ( http://192.168.1.1 , I think, for the Linksys.)

 

Then, check your Mac's System Preferences / Network pane. set the Show: pull-down to Airport, then go to the TCP/IP tab. I presume it says "Configure:" "Using DHCP". See if you have an IP Address, Subnet Mask, and Router values filled in.

 

macx3_net_ap_dhcp_ip.jpg

 

For the LinkSys, I think it should be IP Address: 192.168.1.101 (last digit may vary), Subnet Mask: 255.255.255.0, and Router: 192.168.1.1.

 

What you don't want to see is an IP Address starting 169.xx.xx.xx.

Share this post


Link to post
Share on other sites

Thanks:

 

Can connect to Linksys router wirelessly at http://192.168.1.1 Configuration looks right. When I try to save, get Safari's "Not connected to internet" message and Network Diagnostics launches. All is green except internet. Have run through this a couple times and Network Diagnostics it can't fix it.

 

My Network pane appears precisely as you suggested, with correct IP address.

 

Any thoughts on next steps?

Share this post


Link to post
Share on other sites
Can connect to Linksys router wirelessly at http://192.168.1.1 Configuration looks right. When I try to save, get Safari's "Not connected to internet" message and Network Diagnostics launches. All is green except internet. Have run through this a couple times and Network Diagnostics it can't fix it.

 

My Network pane appears precisely as you suggested, with correct IP address.

 

Any thoughts on next steps?

Sorry, I've been tardy in this reply....

 

Given that you can connect as far as the Linksys admin app and have a good IP address...

 

 

Do you have any other systems on your home network ? E.g., do you use local file sharing or iTunes music sharing with another Mac in the house? If so, can the Macbook reach that ? E.g., if you select "Network" from Finder's "Go" menu, are there any other in-house Macs listed ?

 

I'm thinking the problem is with the DNS (which looks up the "apple.com" style name to get an IP address for TCP/Ip access.). Do you have any explicit DNS (name server) configured for either Ethernet or Airport configs ?

 

You could try manually entering a DNS address in the "DNS Servers:" field (Network System Preference, Show; Airport, TCP/IP tab.) OpenDNS uses 208.67.222.222 and 208.67.220.220. Those should work for anyone.

 

Another thing to try is to open the System Preferences' Network pane, use the "Location:" pull-down to access "New Location". The new location will give you a blank slate to re-enter all your network preferences, in case something is corrupt there. (You can always re-set the Location pull-down to its original value to restore the old network settings if that doesn't work out.)

 

Try the above before I geek you out...

I apologize for geekishly digging down to the Terminal's networking command set in the following...

 

Try this in Terminal:

Type the command "nslookup apple.com" (without the quotes) and Return. (That does a DNS lookup of the name "apple.com")

A good reply is:

Server:         68.6.16.30
Address:        68.6.16.30#53

Non-authoritative answer:
Name:   apple.com
Address: 17.149.160.49

(Your DNS server probably won't be 68.6.16.30. That's Cox cable's DNS.)

 

And, try this in Terminal:

Type the command "route get apple.com" (without the quotes) and Return.

A good answer is:

   route to: apple.com
destination: default
      mask: default
   gateway: 192.168.1.1
 interface: en1
     flags: <UP,GATEWAY,DONE,STATIC,PRCLONING>
recvpipe  sendpipe  ssthresh  rtt,msec    rttvar  hopcount      mtu     expire
      0         0         0         0         0         0      1500         0 

The "gateway: 192.168.1.1" and "interface: en1" indicate the route runs through your LinkSys (192.168.1.1) via the Airport (en1).

 

 

Try this in the Terminal:

Type "telnet -N 17.112.152.32 80" (without the quotes) and press Return. The likely reponses are either a quick

Trying 17.112.152.32... 
Connected to 17.112.152.32. 
Escape character is '^]'

 

or, it will reply just

"Trying 17.112.152.32..."

and just sit there for a minute before adding "Operation timed out".

 

The former would definitely imply a DNS problem. (Try the further command, "telnet www.apple.com 80" and Return to see.) (Both those commands open a browser-port connection to Apple.com, the first without using the DNS to resolve the name "www.apple.com", and the second using the DNS name lookup.)

 

It's also possible that there's a second computer on your home network (including a network printer) that has the same IP address as your Mac is getting from the LinkSys DHCP server. (Usually the Mac reports that with a pop-up message about another computer using the same IP address.) That could confuse the LinkSys enough for it to route all your data to the wrong computer. You could bypass that possibility by changing the System Preferences / Network Pane / Show: Airport / TCP/IP tab to "Configure: Manually" and entering 192.168.1.88, 255.255.255.0, 192.168.1.1 - which manually sets your Mac's IP to 192.168.1.88 (which is outside the range of the LinkSys's default DHCP server settings, 101.)

 

Sorry this is so long and messy - I wanted to cover as many things as possible in one fell swoop.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing

    No registered users viewing this page.

  • Who's Online (See full list)

    There are no registered users currently online

×