Jump to content
in2mac

External HD works with powerbook - not iMac- Why?

Recommended Posts

I have a 320 GB external Western Digial HD that for some reason works perfectly fine with my 12" powerbook 1ghz G4 but will not work with my 1 ghz G4 iMac (lampshade). They are both running OSX 10.4.10 and have enough memory (powerbook 768mb and the iMac 1.25 mb). I am using a firewire cable on both computers since I do not have USB 2.0 on either computer.

 

The external drive was working for awhile with the iMac with no problems but recently it was acting funny - I was unable to access the drive for backup and could not UNMOUNT the drive - I had to unplug it to unmount and remove the drive. It was screwing up my whole system - making it slow.

 

I called Western Digital and in the course of their help found that when I attached it to my 12' Powerbook it worked perfectly fine. No problems at all. So I copied all the files that I wanted to save onto disks and then erased and reformatted the HD. It has 3 partitions - File Storage 160GB, iMac dup 90GB, and Powerbook dup 50GB .

 

After erase and reformat i was able to put some of the files back on the external drive. I attached it to the iMac. It mounted the volumes ok but when I tried to add some files to the external drive it could not - came back with error message that the files could not be read or transferred to the external drive for some reason.

 

Does anyone know why the iMac should have this problem? Is there a fix that I can do?

Could it be a virus or some "switch" or program that is screwing up the iMac?

Is the memory corrupted on the iMac?

 

How can I do a diagnosis to find out the problem?

 

I did run Onyx on the iMac to do all the maintenance on the hard drive.

 

Please advise.....

 

Allan

Share this post


Link to post
Share on other sites

Sounds to me like a problem with the iMac rather than the drive. I assume you use the same cable on both machines, so that shouldn't be it. You may have a bad firewire port on the iMac. I'd try plugging it into the other firewire port first (pretty sure there are 2).

Share this post


Link to post
Share on other sites

It could be the Firewire port on your iMac is defect. If you insert the installation CD/DVD for the iMac into its drive and boot up with the 'c' key pressed, you should be able to select an option to perform a Hardware Test.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing

    No registered users viewing this page.

  • Who's Online (See full list)

    There are no registered users currently online

×