Jump to content
Sign in to follow this  
Leon

Transparent menu bar in Leopard

Recommended Posts

Hello everyone!

I have a problem (at least I think I do..):

The menu bar bar in my Leopard is not transparent :(

Look at the screenshot: picture1pl8.png

Isn't suppose to be transparent?

How can I make transparent?

 

Thanks, Leon.

Edited by Leon

Share this post


Link to post
Share on other sites

There are several utilities going around to remove transparency from the menu bar by people who don't like it. e.g., Opaque Menu Bar and Menu bar Tint. I assume you have not installed these, or you would be aware of it ?

 

Out of curiosity, what info do you get from typing this command in terminal:

 

defaults read /System/Library/LaunchDaemons/com.apple.WindowServer

 

There's an article on using that plist to modify menu bar behavior on Leopard here: http://db.tidbits.com/article/9320

Share this post


Link to post
Share on other sites

i think i remember hearing that on some G4's or relatively older machines, the menu bar is opaque. i think it has to do with the limitations of the machine, and it is purposely done that way, its not a "bug". there are discussions on apple's support site and others talking about this. i never did see the resolution though. not sure if there is one.

Share this post


Link to post
Share on other sites

When typing 'defaults read /System/Library/LaunchDaemons/com.apple.WindowServer', I get this:

 

{

Label = "com.apple.WindowServer";

MachServices = {

"com.apple.windowserver" = 1;

};

ProgramArguments = (

"/System/Library/Frameworks/ApplicationServices.framework/Frameworks/CoreGraphics.framework/Resources/WindowServer",

"-daemon"

);

}

 

Is that alright?

Also, I actually do have a G4, a first gen mini.

Any way, Is there a way to force the menu bar to be transparent even if it's a G4?

Thanks you guys.

Edited by Leon

Share this post


Link to post
Share on other sites

Your graphics system needs to support Core Image, which I don't believe that Mini does. It's the same on my 867mhz TiBook. Frankly, I'd be happy. I'm looking for a good way to turn that off that doesn't rely on modifying the background image's cache.

Edited by Trium Shockwave

Share this post


Link to post
Share on other sites
I'm looking for a good way to turn that off that doesn't rely on modifying the background image's cache.

See that article I mentioned earlier: http://db.tidbits.com/article/9320 It shows how to use the good old "defaults" command to set the Leopard option for the menubar so it's not transparent (your choice of glaring white or dull gray.)

 

There's also a pretty good collection of Leopard GUI tweeks here: http://www.usingmac.com/2007/11/18/leopard...-terminal-codes

Edited by car1son

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing

    No registered users viewing this page.

  • Who's Online (See full list)

    There are no registered users currently online

×