Jump to content
mrstucci

setting up WPA security- having troubles.....

Recommended Posts

Hi- we have 3 computers here at our house and I am trying to close our network. I want to do a WPA setup. I have been successful doing it on my MBP without problem but my hubby's computer is another matter. It's a G4 running Tiger (I have Leopard- our son has a Dell with Linux) and each time I have thought I had it right, it ends up with no internet connection at all. It can't find the network. So right now our network is open. Also, for some reason on my MBP, I see our neighbors computers in the list in the menu bar for the airport. But only on my MBP (brand new)- never saw them listed on my G4 nor on my husband's G4. And my connection on my MBP is up and down. But the bigger issue is the lack of security on our setup. I have tried at least 5 times to set it up on my hubby's G4 and each time he loses any connection to the internet- no signal- can't find the base station. We have an AirPort Extreme. So if anyone can advise how to go about fixing this issue, I would be very grateful! Judy

Share this post


Link to post
Share on other sites

Part of your issues is mixed operating systems. I don't have Leopard, but it's my understanding that Leopard shows other networks in the menu bar. That would be why you see the neighbors with your MBP.

 

This is a matter of first setting up the network so that all the computers can see and connect to it, which you need to do by administering the Airport Extreme. It's generally fairly straightforward but wifi networks, in general, always have idiosyncrasies. It's possible the airport/wifi cards in the G4 and Dell can't do WPA but I have no way to know that.

 

Launch the Airport Utility and use the setup assistant to use DHCP with no security and go from there, machine by machine, until you can connect them that way. Then, enable WEP first and, machine by machine, get connected. Finally, move on to WPA, making sure that it's available to the G4 and Dell connection utilities.

Share this post


Link to post
Share on other sites

Thanks for replying. The Dell does do WPA. In my rooting around the different apps trying to set this up, I did see the option for the G4 to run WPA. So it's just a matter of getting them all set up so that they all work! My son and husband said not to worry about setting up a secure network- none of them are secure really and anyone can break in..... Judy

Share this post


Link to post
Share on other sites

I don't have Leopard either but I assume by "Menu Bar" you simply mean clicking on the AirPort icon and seeing the drop-down list - common on all Mac OS X releases as far as I know. You're probably seeing your neigbour's wireless networks as the MBP has a higher-gain aerial than the G4s past and present.

 

As for securing your network this is a nice summary of where things stood last October - including the point that Linux supports WPA - though it doesn't mention WPA2 for that operating system.

 

The wireless strength problem you have could be down to one of a number of issues - about which see this.

 

Quite why the G4 connects but doesn't see the Internet yet the other computers do is a bit of a mystery. The other contributor's suggestion look about right but take a look at this too.

 

I have a G4 and two Intel Mac minis sharing my Internet connection via an AirPort wireless network using an AirPort Express unit running WPA2 so, as you'd expect, all should work.

Share this post


Link to post
Share on other sites

Yeah with leopard its shows allot of networks but on my connection its says i need either a WPA or WEP key what's that?

Share this post


Link to post
Share on other sites

First you should do what Huskerman said. Set up the network with no security at all, just to make sure you're not having any problems with the basic signal or any hardware problems.

 

Then set it up with WEP security (this is the useless one your husband was talking about - WPA is actually pretty secure).

 

Then finally, when it's been working with no security and WEP, set it up with WPA.

 

You set either the WEP or WPA key depending on which kind of encryption you use. You don't specify which kind of router you have, so I'm afraid I can't give you any more pointers on how to set it up on that end. And what disrtro / version of Linux is your son using? Lots of the older ones have trouble with connection to WPA networks.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing

    No registered users viewing this page.

  • Who's Online (See full list)

    There are no registered users currently online

×