Jump to content
Ajax

iPod Touch WiFi problem

Recommended Posts

Hi all,

 

I am having problems connecting (or should I say not connecting) via WiFi on my home network with my iPod Touch. My iPod Touch shows that I have a clear WiFi signal but when I go to Safari and try to get online I get the following message:

 

"Safari can't open the page because it can't find the server."

 

When I go into settings/Wi-Fi Networks, under choose a Network my WiFi network is shown and I can inter my password and it shows my network with a "check mark" next to it. Then when I touch the blue arrow for the next screen, with DHCP selected, this screen shows the following:

 

IP Address: 169.254.68.52

Subnet: 255.255.0.0

Router:

DNS:

Search Domains:

Client ID:

 

HTTP Proxy is off.

 

Sometimes it will give a DNS, sometimes not, like now. I always get an IP address starting with 169. I read somewhere that an IP Address starting with 169 is what will show up if it can't find the correct IP Address or something like that.

 

I have had no problem getting my iPod Touch connected on free WiFi in other locations, such as the library, hotel while traveling, a local cafe, my father's home network, etc.

 

I have tried reseting my iPod Touch, and when that didn't work I tried reinstalling when connecting to iTunes and that didn't work. Someone told me to try lowering the security setting on my Airport Express, so I went from WPA2, to WEP, to no security and I couldn't connect at any of these settings. (I have it currently set to WEP).

 

Does anyone have any idea what's up and how to fix or correct this? I would appreciate any help on this.

 

Thanks. :blink:

Share this post


Link to post
Share on other sites

Sounds like a router setup problem. I don't have an Airport, so I can't help you there. Do you have any other wifi devices that connect successfully to the router? You should probably see you router's IP address in both the Router and DNS fields. Is the router set up to do DHCP correctly?

Share this post


Link to post
Share on other sites

It's clearly a router problem, and I agree, it looks like you have DHCP turned off.

 

And you're thinking of a 169.192.xxx.xxx IP, which is a local IP, which is in fact what you want to be showing up there.

Share this post


Link to post
Share on other sites
Sounds like a router setup problem. I don't have an Airport, so I can't help you there. Do you have any other wifi devices that connect successfully to the router? You should probably see you router's IP address in both the Router and DNS fields. Is the router set up to do DHCP correctly?

 

 

Scoates,

 

Well, I have my laptop connected through the router. It is a PowerBook G4 with an Airport Extreme card. My sister's MacBook will also connect wireless through the router when she brings it over. I don't think I have anything else wireless to try other than my iPod Touch. I'm not sure how to check if the DHCP on the router is set up correctly. On my PowerBook in the System Preference under Network it shows that under TCP/IP it is configured using DHCP and an IP Address, a Subnet Mask, and a Router are listed that do not show up or are different than on my iPod Touch. I'm not sure if that information is helpful. How do I check if the routers DHCP is setup correctly?

 

Thanks.

Share this post


Link to post
Share on other sites

Depends on what router you have, since they're all different. Generally, there's a web page you need to log into. There will be somewhere in the network settings that says whether DHCP is enabled or not. Without knowing which router you have I can't go into more detail. One thing you might want to try is to restore your network settings. Bear in mind that I have an iPhone, so it may be different, but I expect it to be the same. Go to settings -> general -> reset and then choose reset network settings. Since your macs are finding the network ok, this may well fix it. If not, post back with your specific make and model of router.

Share this post


Link to post
Share on other sites

Another thing you could try is to turn on internet sharing on your PowerBook and see if the touch can access the connection that way. I realize it's not an ideal solution, but it may hold you over until you figure out the main problem.

Share this post


Link to post
Share on other sites
Depends on what router you have, since they're all different. Generally, there's a web page you need to log into. There will be somewhere in the network settings that says whether DHCP is enabled or not. Without knowing which router you have I can't go into more detail. One thing you might want to try is to restore your network settings. Bear in mind that I have an iPhone, so it may be different, but I expect it to be the same. Go to settings -> general -> reset and then choose reset network settings. Since your macs are finding the network ok, this may well fix it. If not, post back with your specific make and model of router.

 

I tried resetting network settings on my iPod Touch and unfortunately that did not fix the problem.

 

My wireless router is an Apple Airport Express Base Station (802.11g), which is the smaller older Apple router that plugs directly into an electrical outlet, model number A1084. Is this the router information you asked for?

 

When I originally set up the wireless router I did not go to a web page to set anything up. It came with Airport Utility software and Airport Admin Utility software. Within the Airport Admin Utility under configure, the Internet setting is currently set to configure using DHCP. Not sure if that is helpful.

 

Thanks.

Share this post


Link to post
Share on other sites
Another thing you could try is to turn on internet sharing on your PowerBook and see if the touch can access the connection that way. I realize it's not an ideal solution, but it may hold you over until you figure out the main problem.

 

I thought I would try your suggestion so I went into System Preferences to turn on internet sharing and I got a somewhat scary caution message that said something like: "If you turn on this port, your Internet Service provider might terminate you service to prevent you from disrupting it's network." So, being the cautious person that I am, I did not turn it on. Should I ignore this message and give it a try or should I take the warning seriously?

 

Thanks.

Share this post


Link to post
Share on other sites
When I originally set up the wireless router I did not go to a web page to set anything up. It came with Airport Utility software and Airport Admin Utility software. Within the Airport Admin Utility under configure, the Internet setting is currently set to configure using DHCP. Not sure if that is helpful.

 

It does help. There may be some discrepancies between what you see and what I'm about to tell you, because I'm looking at an AirPort Extreme (instead of Express) base station, and I'm using AirPort Utility 5.2.1. But that may be close enough. Something you said might explain everything.

 

It looks like you are currently configured so that your ISP has a DHCP server that is handing out one IP address to you. Your AirPort base station is configured to "extend" that connection. That is, it's not providing any added value; in particular it's not doing NAT. Your laptop is grabbing that one IP address. When your iPod Touch tries to connect, it does make a successful link-level connection as far as your base station, but when it then tries to configure IP over that connection, the base station simply forwards its DHCP request to your ISP. Your ISP won't permit a second device on the line, and doesn't respond to the DHCP request. Not seeing a DHCP server, the Touch falls back to a self-assigned IP address, in the 169.254/16 range. That IP address won't work outside the link.

 

What you need to do is change the base station's "wireless mode" (in the AirPort pane of AirPort Utility) to "Create a Wireless Network". This activates the DHCP/NAT functionality in the base station.

 

When you now go to Internet pane of AirPort Utility, you'll find that instead of one sub-pane ("Internet Connection") you now have three sub-panes ("Internet Connection", "DHCP", and "NAT").

 

"Internet Connection" refers to how your base station talks to your ISP. Leave that alone.

 

"DHCP" and "NAT" refer to how your devices connect to the base station. Your base station is now a DHCP server for your local devices, and will use NAT to split the one IP address it gets from the ISP to a range of local addresses that it hands out to your devices.

 

You'll have several options under DHCP, but the beauty of it is that just about all of your options work equally well. It's pretty hard to misconfigure this part of it. You'll have three choices for DHCP range; they'll all work fine on a simple network like yours. The third number in the DHCP range can be anything from 0 to 255. The DHCP beginning/ending range can be any subset of 2..254; the default 100..200 is fine. (This is the range that will be handed out to devices that haven't been assigned a fixed IP address.)

 

Under NAT, you probably want to turn on "Enable NAT Port Mapping Protocol"; Back To My Mac will need that. The rest of that sub-panel essentially constitutes your firewall. No incoming connections will get through unless you enable them here.

Share this post


Link to post
Share on other sites

I had the same problem and called apple. Although they were stumped while on the phone I figured it out.

- Go into your router settings under basic setup (on my linksys) - there is a setting for Maximum number of DHCP users" mine was on 5, and I bumped it to 10. Wifi worked great after that.

(FYI-mine had worked up until today when I connected more devices-then ipod stopped working. - so I knew my network was available)

Share this post


Link to post
Share on other sites

Welcome to the forum, klevey.

 

And, THANKS!!!

 

I've been having this exact NAGGING problem with my iPhone and, I thought, my Airport Extreme (see WiFi problem - Was my iPhone now my iBook )

 

I had reset and restored the iPhone, reset the base station, etc and just couldn't figure it out. What I didn't realize was that I have an extra machine hard wired into the network (while I set it up for my 5 yr old niece) that took the last IP. I was thinking WiFi when in fact it was just NAT.

 

I also have a wired LinkSys between the cable modem and the AE. Changed the client number and VOILA.

Share this post


Link to post
Share on other sites
It does help. There may be some discrepancies between what you see and what I'm about to tell you, because I'm looking at an AirPort Extreme (instead of Express) base station, and I'm using AirPort Utility 5.2.1. But that may be close enough. Something you said might explain everything.

 

It looks like you are currently configured so that your ISP has a DHCP server that is handing out one IP address to you. Your AirPort base station is configured to "extend" that connection. That is, it's not providing any added value; in particular it's not doing NAT. Your laptop is grabbing that one IP address. When your iPod Touch tries to connect, it does make a successful link-level connection as far as your base station, but when it then tries to configure IP over that connection, the base station simply forwards its DHCP request to your ISP. Your ISP won't permit a second device on the line, and doesn't respond to the DHCP request. Not seeing a DHCP server, the Touch falls back to a self-assigned IP address, in the 169.254/16 range. That IP address won't work outside the link.

 

What you need to do is change the base station's "wireless mode" (in the AirPort pane of AirPort Utility) to "Create a Wireless Network". This activates the DHCP/NAT functionality in the base station.

 

When you now go to Internet pane of AirPort Utility, you'll find that instead of one sub-pane ("Internet Connection") you now have three sub-panes ("Internet Connection", "DHCP", and "NAT").

 

"Internet Connection" refers to how your base station talks to your ISP. Leave that alone.

 

"DHCP" and "NAT" refer to how your devices connect to the base station. Your base station is now a DHCP server for your local devices, and will use NAT to split the one IP address it gets from the ISP to a range of local addresses that it hands out to your devices.

 

You'll have several options under DHCP, but the beauty of it is that just about all of your options work equally well. It's pretty hard to misconfigure this part of it. You'll have three choices for DHCP range; they'll all work fine on a simple network like yours. The third number in the DHCP range can be anything from 0 to 255. The DHCP beginning/ending range can be any subset of 2..254; the default 100..200 is fine. (This is the range that will be handed out to devices that haven't been assigned a fixed IP address.)

 

Under NAT, you probably want to turn on "Enable NAT Port Mapping Protocol"; Back To My Mac will need that. The rest of that sub-panel essentially constitutes your firewall. No incoming connections will get through unless you enable them here.

 

 

ganbustein,

 

That worked! I went into the my Airport Admin Utility software and changed the settings so that IP Address is shared and now my iPod Touch's WiFi is working fine on my home network! My Airport Admin Utility software for the Airport Express is some what different from what you described for your Airport Extreme, but because of your well written and thorough explanation of what was causing the problem I was able to easily figure it out and make the appropriate changes. So if anyone else is having this problem see ganbustein's post above.

 

Thanks to everyone for your input and help, it is greatly appreciated! :)

Share this post


Link to post
Share on other sites

Hi all, I'm having the exact same problem connecting my Ipod touch to my Imac. The Imac has an airport extreme card but it does not show up in the airport utility. is there another way to change all of those settings or to get the utility to recognize my card. Thanks.

Share this post


Link to post
Share on other sites

You mac won't show up in airport utility, its meant for airport base stations. If for some reason you want to do wireless networking without a router (which is so incredibly flaky, even now I really would advise that you save yourself the hassle and just pick up a cheap router), you'll need to set up what apple calls a computer to computer network.

 

Choose Create Network from the airport icon in the menu bar. Then you'll need to set up internet connection sharing, and probably a few other things. Just trust me on the getting a router thing. It will save you much faffing about.

Share this post


Link to post
Share on other sites

This might not work but it worked on my mac when me and my dads macbooks kept canceling the others internet. Go into settings then wifi and click the little button next to your network, then click static and change only the IP address to 192.168.0. something , 4, 5 depending on how many wireless computers you've got. Though it probably won't work.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing

    No registered users viewing this page.

  • Who's Online (See full list)

    There are no registered users currently online

×