Jump to content
jassigal

Podcast Suddenly Stopping in the Middle

Recommended Posts

Recently, my podcast (actually, I've really seemed to expereince the problem only when listening to the MacCast, and cant recall having the problem with the other podcast I subscribe to) will just suddenly stop in the middle of the track. Ill be listening to it, and all the sudden, it stops and returns to the beginning point. Ill try and "scroll" back to right before the time it stops at, and it does the exact same thing at the exact same time point.

 

If I "scroll" anywhere beyond the point where the podcast stops in iTunes and push play, it again just goes back to the very beginning. It also seems to be doing this when I try and listen to the same episode on my iPod.

 

Is this something wrong with my computer/iTunes? I hate not being able to listen to the entire episode of the Maccast!

Share this post


Link to post
Share on other sites
Recently, my podcast (actually, I've really seemed to expereince the problem only when listening to the MacCast, and cant recall having the problem with the other podcast I subscribe to) will just suddenly stop in the middle of the track. Ill be listening to it, and all the sudden, it stops and returns to the beginning point. Ill try and "scroll" back to right before the time it stops at, and it does the exact same thing at the exact same time point.

I've had this exact same problem with ordinary music. I don't think it has anything to do with the track being a podcast.

 

What worked for me was to recopy the track to the iPod. In iTunes, uncheck the problematic track, sync the iPod (which will remove the track from the iPod, assuming you have "synchronize only checked tracks" set), then check the track again, and sync the iPod again.

 

I ascribed the problem to marginal sectors on the iPod's disk. Sometimes data written to those tracks gets written correctly, other times it's written with incorrect parity. Disk drives do not normally detect this kind of write error until you try to read the sector back.

Share this post


Link to post
Share on other sites

Thanks, Ill give this a try...

 

But would this explain why its doing it on my computer, in iTunes as well? I understand what your saying about it not copying it to my iPod correctly the first time, but it will stop at the exact same time on in my iTunes, before I even try and copy the podcast to my iPod.

Share this post


Link to post
Share on other sites
But would this explain why its doing it on my computer, in iTunes as well? I understand what your saying about it not copying it to my iPod correctly the first time, but it will stop at the exact same time on in my iTunes, before I even try and copy the podcast to my iPod.

Oh, sorry. I just assumed that because I listen to podcasts on my iPod that everyone does. I shouldn't make silly assumptions like that, especially since there are some podcasts I listen to on my computer.

 

If it won't play right in iTunes, I'd guess you just got a bad download. Try downloading it again.

 

To re-download an episode, delete it (just the one episode) from iTunes, collapse the episode list for that subscription and then re-open the list while holding down the option key. iTunes will re-list all missing episodes with a {Get} button next to each that you can use to fetch it again.

Share this post


Link to post
Share on other sites

I deleted the "problem-ed" podcast and re-downloaded it, and it seems to be working this time. Thanks for your help!

Share this post


Link to post
Share on other sites

i had the same thing happen to me but i was wondering how i can get it to go away forever?

it happens every week with diggnation and very often with leo laports tech guy. i have to re-download the podcast at-least 3 times before i get the whole thing.

Share this post


Link to post
Share on other sites

The only way is to not download it as soon as it's released, wait a day or two. With the popular podcasts this is caused by a server problem (or possibly your internet connection if you're on a cheap and nasty connection). Things are just too overloaded and the download is crapping out.

Share this post


Link to post
Share on other sites

i did that. i waited at least 4 days but they still keep messing up!!

 

i also get an error code "err = -3260"

 

some podcasts dont download the whole episode, some show they download all the way but stop playing halfway throught. i have even had this problem this shows from the maccast!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing

    No registered users viewing this page.

  • Who's Online (See full list)

    There are no registered users currently online

×