Jump to content
Sign in to follow this  
tmack

iPhone and Public Wifi

Recommended Posts

I am sure many of you have had this problem: You are out in public, you glance down at your iPhone, and it asks you if you want to join whatever network. You try it and just when you think you're gonna get free wifi in a public place... "Cannot Connect"!

 

Does anyone have any tips for making the wifi connect in a public place? I have gone to the airport, and was able to be routed to their "License Agreement" page no problem. It connects fine on my home network, but places where I know there is free wifi, nothing. It shows that there is wifi, and gives me the little radio waves icon, but either the gear spins forever, or it just cannot connect.

 

Thanks Maccasters,

Share this post


Link to post
Share on other sites

I don't think there is much you can do - establishing the wifi connection is only the first link in the chain to wherever you want to get to. The rest of the chain is out of your hands - so if someone happens to have a switched on wifi router that's either not plugged in to DSL or some such, or is not configured properly, your request will go nowhere.

 

The only free wifi I've ever seen working (UK) is at MacDonalds (actually I was sitting in the car park next door - I don't like their food!)

Share this post


Link to post
Share on other sites

They could also be using MAC filtering. The network appears to be open, but when you try to obtain an IP address, if your iPhone's MAC isn't in the allowed list, it will tell you to get lost. As scoates said, there's not a great deal you can do. If it's working in some places but not others, the problem is with the network you're trying to connect to.

Share this post


Link to post
Share on other sites
They could also be using MAC filtering. The network appears to be open, but when you try to obtain an IP address, if your iPhone's MAC isn't in the allowed list, it will tell you to get lost. As scoates said, there's not a great deal you can do. If it's working in some places but not others, the problem is with the network you're trying to connect to.

Graham is quite correct.

In my travels, I have seen a lot of this.

I just turn off the Wi-Fi nag and just go to the Wi-Fi Settings when I'm pretty sure it's a connection I should get and just select it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing

    No registered users viewing this page.

  • Who's Online (See full list)

    There are no registered users currently online

×