Jump to content
Vassily

Broadband speed degradation with Time Capsule

Recommended Posts

Hi all,

 

I 'discovered' something peculiar recently and wanted to share this with the rest of you. I am not sure my conclusions are technically accurate but you can judge for yourselves. I use a broadband connection that is rated by my ISP at 20 Mb/s on download. It never gets there but on average it hits 18 to 19 Mb/s, so it's fine! In my subscription contract I was given four external IP addresses of which I use two by means of one Airport Extreme Base Station (of the latest models) and one Time Capsule 500G. Occasionally I got some speed degradation on the Time Capsule and some difficulty to connect to Internet at all. I always cured the problem by resetting it each time that happened (off and on plug on power outlet) and that corrected the problem. Yesterday this happened, but this time I documented the incident more precisely by using http://www.speedtest.net. The Time Capsule appeared to be running this time at one third its normal average. It happened after midnight and I thought it was due to possible ISP caused degradation because of maintenance they often do after midnight. Also, when I performed the test with my Extreme router it showed similar slow results. This morning, I repeated the test and the TC showed again the low speed. I couldn't blame the ISP this time since they are supposed to work fine on normal daytime hours, and even more so as my other router, the Airport Extreme showed the regular high speed. I was pinging few servers in the neighborhood in the process (Brussels, London, Amsterdam, Malmo, Groningen, Rotterdam... yep, I did a whole lotta testing). New TC tests showed again the same slow download speed. BTW, it was only those download speeds that were affected. My upload is slow (an issue for cable connections, about 512 Kb/s rated, 480 Kb/s on average).

 

I then reset my TC and tested again. Wundebar! All back to normal!

 

Since I am using the same physical cable connection and the signals travel physically thru the same paths to my ISP's outlet and both routers (both on the 11n draft spec, btw) are connected to the same ISP modem, after experiencing what I described, I must conclude (in my own low level tech knowledge of such things) that this should be a software glitch on Apple's routers... I am not suggesting only the TC has the problem though. I am sure I had this with the Airport Extreme as well but I have no concrete numeric proof as I didn't know or use the speedtest.net at that time.

 

Anyways, if anybody has additional knowledge to enlighten me on this, I'd much appreciate.

Share this post


Link to post
Share on other sites

It all depends on how your network is set up. Are they connected via ethernet? By extending the same wireless network? Two networks linked with WDS? There are so many options, we'll need more information.

Share this post


Link to post
Share on other sites

Nope, they are independent, work on their own, not extending each other, have got their own IPs to the outside world and the two WLANs are not linked whatsoever. Does this help?

Edited by Vassily

Share this post


Link to post
Share on other sites

Firstly I'd try disconnecting the extreme. ISP's usually dish out total crap hardware, so I'd eliminate all other possibilities before blaming apple. I'd also try restoring the firmware on the time capsule. Let's put it this way, I've installed several of these and haven't run into this problem.

Share this post


Link to post
Share on other sites

Go to Airport Utility, choose the time capsule, choose manual setup (cmd-L). From the basestation pull down, choose upload firmware, then upload the most recent version.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing

    No registered users viewing this page.

  • Who's Online (See full list)

    There are no registered users currently online

×