Jump to content
Sign in to follow this  

'Unknown error occured (6)' with Touch 2.0 upgrade

Recommended Posts

I had no problem paying and downloading the software, iTunes had my iPod Touch backed up without any problem either. But it just wouldn't install the freaking software. I kept getting this error message "An unknown error occurred (6)". The 2.0 software would actually start installing, but the error 6 msg will pop up sometimes quite early, say about 1/3 done on the progress bar and sometimes 1/2 done. The most I got one time was about 3/5 done. What does this mean? I don't know. I lost count how many times I tried this and i am very frustrated.

This is what I found on the support page regarding what to do with an error 6 and many other errors (2, 6, 9, -18, -48, -50, 1002, 1011, 1601, 1602, 1603, 1604, 1608, 1609, 1611, 2003, 2004, -9808).




Anyone encountering the same problem, pls check out the support article and try going through the steps Apple suggested there, see if it will fix the problem cause I went through every single one of them (except using a windows machine) and none of them worked.


I have also posted this on Apple discussion as well. There are quite a few people responded to having the same issue.



Any suggestion would help...

Share this post

Link to post
Share on other sites

how much space do you have on your iPod touch? I would make sure that you have about 512MB just to make sure that there is enough buffer... I may be way off, but I know upgrades fail if there's not enough space...

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing

    No registered users viewing this page.

  • Who's Online (See full list)

    There are no registered users currently online