Jump to content
Sign in to follow this  
tmack

Canon drivers missing! Can't Print

Recommended Posts

I have been having this issue for awhile now. Ever since the 02/08 security update, my printers haven't worked the same. My all-in-one MP160 works fine now that I have installed CUPS, and Gutenprint, but my i960 photo printer is not so lucky. When I go to add it to my printer list, the driver for that printer is not listed. I have tried using drivers fro similar printers that are listed, but they do not work. I have even downloaded the driver from Canon's website, but it doesn't seem to install where it should because it is nowhere to be found in the driver list. I know i could probably upgrade my Powermac G4 to Leopard, but i don't feel that should have to when the printer worked fine before. This is unacceptable if you ask me. It seems like it is a ploy to get everyone to move to Leopard. Slowly discontinuing support for things, until you finally have no choice.

 

Anyway, sorry about the rant...

 

I just want to print photos again. Thanks Maccast-ers.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing

    No registered users viewing this page.

  • Who's Online (See full list)

    There are no registered users currently online

×