Jump to content
Sign in to follow this  
jlamb0

Closing My Macbook's Lid

Recommended Posts

In my old Dell laptop there was a preference pane that allowed you to change how the computer behaved when you closed the lid. You could have it sleep, hibernate, or do nothing.

 

Is there a comparable setting in my Macbook? I'd really like to have the option of leaving the computer awake, but closing the lid.

Share this post


Link to post
Share on other sites
Yup.

 

That's kind of dumb...

 

I'm sure there's a perfectly logical explanation, but come on Apple, you couldn't loosen the reins just a little?

Share this post


Link to post
Share on other sites

What about the app InsomniaX?

 

http://www.macupdate.com/info.php/id/22211

 

I use it all the time when I want to just move to another room or something. InsomniaX lives in the menubar with a drop-down menu to "Enable Insomnia". This basically prevents sleep, and when you close your lid your computer acts like nothing happened--it doesn't even shut off the display.

 

I will add a caution, though: since MacBook cools primarily through the keyboard, closing the lid will severely limit airflow (and I suspect this is the reason the feature is disabled from the factory). I don't leave it running with the lid closed for more than 10-15 minutes. I have, in the past, forgotten to disable Insomnia...after about an hour in my sleeve the processor temperature was up around 180 degrees. You just have to be extra careful to disable Insomnia then sleep when you intend to.

 

For this same reason, when using only an external display, I leave the lid cracked a couple of inches and turn the screen brightness all the way down.

Share this post


Link to post
Share on other sites
I will add a caution, though: since MacBook cools primarily through the keyboard, closing the lid will severely limit airflow (and I suspect this is the reason the feature is disabled from the factory). I don't leave it running with the lid closed for more than 10-15 minutes. I have, in the past, forgotten to disable Insomnia...after about an hour in my sleeve the processor temperature was up around 180 degrees. You just have to be extra careful to disable Insomnia then sleep when you intend to.

 

See, there's that pesky logical explanation I was afraid of. Thanks for cluing me in!

Edited by jlamb0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing

    No registered users viewing this page.

  • Who's Online (See full list)

    There are no registered users currently online

×