Jump to content
buckdog

Extremely slow wi-fi, fast ethernet

Recommended Posts

I am working on an Intel iMac that has been moved into a new house. The internet connection by ethernet works perfectly, but when it is hooked up by Wi-Fi, it is extremely slow. The computer is right next to the router (ATT uVerse 2Wire), and the other wireless computer in the house works fine.

 

I tried changing the SSID and network channel (from 11 to 1), but no luck. I also tried making a new location on the computer but also didn't have any luck.

 

Any suggestions?

 

Thanks!

Share this post


Link to post
Share on other sites

Can you describe how it is slow? Like does it hang on a half-loaded page for about 20-30 seconds and then load the rest, or does it just load slow....? If your problem is the same one I had when I got my AirPort Extreme, then I may be able to help you.

 

Apple Geek

Share this post


Link to post
Share on other sites

Sounds like a slow IP address resolution. i had this same problem and i tried everything and the only thing that fixed the problem was a clean install of Mac OS X on my machine and now its Super fast again.

 

I don't know that much about it but it has something to do with the OS's IP address requests.

 

anyways thats what fixed it for me.

Share this post


Link to post
Share on other sites

It takes it forever to load a page and I am not sure, but I don't think it ever finishes, I think that it loads pages to the point where you can look at most of the content but it does not ever get fully loaded.

 

It takes is about 10 seconds to half-load apple's start page.

 

Thanks!

Share this post


Link to post
Share on other sites

are web applications slow? like is msn, iChat, skype, online games etc. are they slow as well or is it just safari and firefox?

Share this post


Link to post
Share on other sites

Ok, if you are using Leopard, try this: System Preferences/Network/Under AirPort click Advanced.../Then under DNS - remove everything on the left box EXCEPT for the first number (it should be greyed out anyway and it should be the address of your router) and add these two numbers - 208.67.222.222 and 208.67.220.220. Then I would restart Safari and maybe anything else that connects to the internet. This worked for me but it may only work for AirPort Extreme routers....

 

I hope this helps.

Apple Geek

Share this post


Link to post
Share on other sites
Ok, if you are using Leopard, try this: System Preferences/Network/Under AirPort click Advanced.../Then under DNS - remove everything on the left box EXCEPT for the first number (it should be greyed out anyway and it should be the address of your router) and add these two numbers - 208.67.222.222 and 208.67.220.220. Then I would restart Safari and maybe anything else that connects to the internet. This worked for me but it may only work for AirPort Extreme routers....

 

I hope this helps.

Apple Geek

 

Those two numbers that were mentioned above are that of OpenDNS.com Their DNS servers are a free alternative to your ISP's DNS servers. OpenDNS will block your network (or just a local machine if your prefer) to phishing and anything else that you may deem inappropriate. Anybody can use them on any computer and there are tutorials on how to make the switch for most standard routers. Of course this will work with your Solaris, Linux, Mac, and Windows operating systems.

 

Brent

Share this post


Link to post
Share on other sites

I tried changing the DNS but no luck. It worked, but was still very slow.

 

I also reinstalled OS X (It's sooo much less painful than reinstalling Windows XP), but I kept having the same problem, so I concluded that it is a problem with the wireless router. The wireless router was weird on a Windows computer with a USB Adapter that ATT provided when they set up the uVerse. It kept disconnecting until ATT finally replaced it with a ethernet-over-power adapter.

 

The problem with the mac is different, but the router seems to just be acting wired, it may be because of all of the other ATT 2Wire networks in the area.

 

Anyways, thanks for the help!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing

    No registered users viewing this page.

  • Who's Online (See full list)

    There are no registered users currently online

×