Jump to content
MnchstrCityBlues

iMac G5 (iSight) will not connect to certain sites - SOLVED

Recommended Posts

Hey Gang:

 

I have an iMac G5 (isight) 10.5.7 and within the past year it has occasionally been unable to connect to secure sites. This problem I can deal with (all it takes it logging out of my personal account, logging in as an administrator, logging out of admin and then logging back into my personal account) but more problems have arisen within the past week.

 

I recently moved to Raleigh and have Time Warner as my ISP. I have set up a network using my Linksys WRT54GL v1.1 running DD-WRT. Since moving I am unable to connect to certain websites (not necessarily secure) from my iMac. On all other computers in the network (such as a Vista laptop and my iPhone) I am able to connect to those same websites. The connection issue seems to be localized to my iMac G5. The websites I am trying to access are not odd or dangerous either. They are sports.espn.go and googlefeed, etc. As an aside, this issue arose before the upgrade to Safari 4.0 (I was using the final stable build of 3 prior to upgrading) and the problem also affects the other browser I use, Bon Echo (Firefox optimized for G5).

 

Has any one encountered this problem? If I can't find a solution I may have to take a scorched earth policy and do a clean install (which will prompt more begging for help on this website lol).

 

Thanks in advance!

 

iMac G5 (iSight) | OS X 10.5.7 | Safari 4 (5530.17)

Share this post


Link to post
Share on other sites

I'd check that you don't have any custom DNS servers set up on your mac. Check System Preferences -> Network -> Your network interface -> Advanced -> DNS

 

If you have any that aren't grey (ie assigned to you by dhcp), you should remove them.

Share this post


Link to post
Share on other sites
I'd check that you don't have any custom DNS servers set up on your mac. Check System Preferences -> Network -> Your network interface -> Advanced -> DNS

 

If you have any that aren't grey (ie assigned to you by dhcp), you should remove them.

 

Unfortunately, all are grayed out

 

I was going to show you a screen shot but imageshack.us is apparently one the websites my iMac no longer likes :(

Share this post


Link to post
Share on other sites

I forgot to add that this is what Safari displays when I attempt to connect to the aforementioned sites:

 

Safari can’t connect to the server.
Safari can’t open the page “http://www.bluemoon-mcfc.co.uk/phpBB2/index.php” because Safari can’t connect to the server “www.bluemoon-mcfc.co.uk”.

Share this post


Link to post
Share on other sites

Can you do a lookup in Network Utility for the effected sites? What about a traceroute? Can you post the results here?

Share this post


Link to post
Share on other sites
Can you do a lookup in Network Utility for the effected sites? What about a traceroute? Can you post the results here?

 

 

Two examples of sites that fail ... (Default Info)

 

Lookup has started ...


; <<>> DiG 9.4.3-P1 <<>> www.bluemoon-mcfc.co.uk +multiline +nocomments +nocmd +noquestion +nostats +search
;; global options:  printcmd
www.bluemoon-mcfc.co.uk. 86400 IN CNAME	bluemoon-mcfc.co.uk.
bluemoon-mcfc.co.uk.	86400 IN A 94.76.213.228

 

Lookup has started ...


; <<>> DiG 9.4.3-P1 <<>> www.finheaven.com +multiline +nocomments +nocmd +noquestion +nostats +search
;; global options:  printcmd
www.finheaven.com.	3600 IN	CNAME finheaven.com.
finheaven.com.		3600 IN	A 174.129.164.57

 

An example of one that doesn't fail ...

 

Lookup has started ...


; <<>> DiG 9.4.3-P1 <<>> www.maccast.com +multiline +nocomments +nocmd +noquestion +nostats +search
;; global options:  printcmd
www.maccast.com.	86389 IN CNAME maccast.com.
maccast.com.		86389 IN A 72.167.142.85

Share this post


Link to post
Share on other sites

Ok, so it's not a dns issue. What about a traceroute? That will show you what path the data is taking from the remote server to your machine.

Share this post


Link to post
Share on other sites
Ok, so it's not a dns issue. What about a traceroute? That will show you what path the data is taking from the remote server to your machine.

 

It seems we may have run across the problem ...

 

Traceroute has started ...

traceroute to bluemoon-mcfc.co.uk (94.76.213.228), 64 hops max, 40 byte packets
traceroute: sendto: No route to host
1 traceroute: wrote bluemoon-mcfc.co.uk 40 chars, ret=-1
*traceroute: sendto: No route to host
traceroute: wrote bluemoon-mcfc.co.uk 40 chars, ret=-1
*traceroute: sendto: No route to host
traceroute: wrote bluemoon-mcfc.co.uk 40 chars, ret=-1
*
traceroute: sendto: No route to host
2 traceroute: wrote bluemoon-mcfc.co.uk 40 chars, ret=-1
*traceroute: sendto: No route to host
traceroute: wrote bluemoon-mcfc.co.uk 40 chars, ret=-1
*traceroute: sendto: No route to host
traceroute: wrote bluemoon-mcfc.co.uk 40 chars, ret=-1
*
traceroute: sendto: No route to host
3 traceroute: wrote bluemoon-mcfc.co.uk 40 chars, ret=-1

 

as opposed to a site that "works:"

 

Traceroute has started ...

traceroute: Warning: www.google.com has multiple addresses; using 209.85.165.147
traceroute to www.l.google.com (209.85.165.147), 64 hops max, 40 byte packets
1  DD-WRT (192.168.1.1)  2.229 ms  1.437 ms  1.408 ms
2  10.116.112.1 (10.116.112.1)  13.280 ms  46.167 ms  8.303 ms
3  rdu-mgx08-vism21.voip.southeast.rr.com (66.26.33.238)  28.821 ms  15.973 ms  11.762 ms
4  fas2-7.rlghncm-rtr1.nc.rr.com (24.25.1.189)  13.906 ms  11.893 ms  28.238 ms
5  srp0-0.rlghncj-rtr5.nc.rr.com (24.25.2.156)  12.455 ms  14.049 ms  12.466 ms
6  pos1-3.rlghnca-rtr2.nc.rr.com (24.25.0.88)  13.446 ms  27.499 ms  19.159 ms
7  ge-2-3-0.chrlncpop-rtr1.southeast.rr.com (24.93.64.176)  20.631 ms  18.779 ms  18.620 ms
8  ae-3-0.cr0.atl20.tbone.rr.com (66.109.6.82)  37.565 ms  38.642 ms  28.272 ms
9  ae-0-0.pr0.atl20.tbone.rr.com (66.109.6.171)  105.837 ms  24.298 ms  31.443 ms
10  66.109.9.90 (66.109.9.90)  29.865 ms  84.956 ms  27.539 ms
11  64.233.174.2 (64.233.174.2)  27.169 ms 72.14.239.100 (72.14.239.100)  30.132 ms  24.282 ms
12  72.14.239.21 (72.14.239.21)  23.318 ms  25.018 ms  135.582 ms
13  216.239.47.146 (216.239.47.146)  46.150 ms 216.239.47.142 (216.239.47.142)  130.290 ms 216.239.47.226 (216.239.47.226)  102.704 ms
14  74.125.198.134 (74.125.198.134)  29.853 ms 74.125.198.6 (74.125.198.6)  24.967 ms 74.125.198.130 (74.125.198.130)  36.480 ms
15  eo-in-f147.google.com (209.85.165.147)  41.942 ms  29.180 ms  138.903 ms

 

 

now, how to fix it? ....

Edited by MnchstrCityBlues

Share this post


Link to post
Share on other sites

Here's a suggestion from my colleague (cos I was pretty stumped) - try deleting the network interface in sys prefs and then re-adding it.

 

You should also ensure that IPV6 is off (as it's highly unlikely you'll be using it), and finally, make sure you don't have anything odd like peer guardian installed. That seems to be notorious for screwing up things like this.

Share this post


Link to post
Share on other sites
Here's a suggestion from my colleague (cos I was pretty stumped) - try deleting the network interface in sys prefs and then re-adding it.

 

You should also ensure that IPV6 is off (as it's highly unlikely you'll be using it), and finally, make sure you don't have anything odd like peer guardian installed. That seems to be notorious for screwing up things like this.

 

I did as you suggested (deleted my ethernet & airport interfaces, turned IPV6 off and quit Peer Guardian; re-added ethernet & airport interfaces) but no change. Any chance this a certificate/key chain issue? My keychain occasionally gives me fits when connecting to secure sites (i.e. it won't let me whereas the administrator profile will let me).

 

Once again, thank you so much for your help and time!

Edited by MnchstrCityBlues

Share this post


Link to post
Share on other sites

Not only should you quit peer guardian, you should uninstall it. No, this is a routing issue, not a keychain one.

Share this post


Link to post
Share on other sites
Not only should you quit peer guardian, you should uninstall it. No, this is a routing issue, not a keychain one.

 

That did the trick! You are a life-saver, Graham. Thank you!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing

    No registered users viewing this page.

  • Who's Online (See full list)

    There are no registered users currently online

×