Jump to content
andyeb

Apple Mail search not working

Recommended Posts

I have a frustrating problem with Apple Mail - when I search messages using the search box in the top right of the UI, it's no longer finding messages which I know contain the string I'm searching for. I have "All Mailboxes" and "Entire Message" selected in the search options bar.

 

I've already tried reindexing my messages by following this article:

 

Mail 3.0 Help: About reindexing

 

However this has not solved the problem.

 

Does anyone know how to resolve this problem? I have two POP accounts and one inactive mac.com account.

Share this post


Link to post
Share on other sites

Is this on Leopard? If so, try the following:

 

Quit Mail

 

Go to ~/Library/Mail and move the file called Envelope Index to your desktop (or anywhere outside of the ~/Library/Mail folder you like).

 

Start Mail. It will say that it's importing your mail - don't worry. It's just rebuilding the database of your mail from the .eml files on your mac.

 

If this fixes the problem, feel free to delete the old Envelope Index from wherever you moved it.

Share this post


Link to post
Share on other sites

Hi Graham,

 

Thanks for your help.

 

Yes, this is on Leopard. I already tried the Envelope Index trick - it was part of the Apple support article I linked to.

 

Any other ideas for things to try?

 

thanks,

 

Andrew

Share this post


Link to post
Share on other sites

Hmm, very odd. You could archive the mailboxes and re-import them? If that works, delete the pop accounts (remember to archive your sent as well!) and add them again, then drag the mail back to where it should be.

 

Or, you could go the whole hog after archiving and delete your entire mail library folder to make sure you're getting a fresh start - after making a backup first, obviously!

Share this post


Link to post
Share on other sites

I hate it when I search for something I know is there, and it stares at me like I'm crazy.

I've had success Rebuilding my folders, might help with mailboxes, too. (on the Mailbox menu.)

Share this post


Link to post
Share on other sites

Removing the Envelope file a second time fixed it, or at least enabled me to find the email I was specifically looking for. I just also tried rebuilding the folder as you suggested and now I'm finding even more results for the same search.

 

Thanks for your help guys.

 

Andrew

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing

    No registered users viewing this page.

  • Who's Online (See full list)

    There are no registered users currently online

×