Jump to content
My Emac

Powerbook G4 wont start up why?

Recommended Posts

I got a question for ya my cousin has a powerbook G4 1.5ghz with 80gb of HD and 1gb ram and his computer was working all fin untill the other nite when he tried to turn it on and it went to his log in screen and hew started to type his password in and the screen went all black with a yellow line going horizontal and then had to be turned off and then we turned it off and tried to start it up the next day and it turned off and then we turned it back on and the fans just went really fast but no picture on the screen nothing and now im starting to think its the ram or logic board but just seeing what you think.

 

 

Cheers My Emac

Share this post


Link to post
Share on other sites

Does kinda sound like the logic board, but on the chance it's something to do with the internal HD, you could try booting from an external source.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing

    No registered users viewing this page.

  • Who's Online (See full list)

    There are no registered users currently online

×