Jump to content
Flyingjeff

USB Drive share changing permissions

Recommended Posts

Hey all!

 

I am surprised that this is the first post that I need to make here due to the great advice I was able to find already covered.

 

My issue is this:

 

I have a 500Gb USB drive connected to my 20" iMac that is set as Shared. This drive appears on my windows machines as an available folder, and I can access it from my Windows machines with no issue. I can add files, directories etc with no issue.

 

I have recently been trying to scrape data for the media library that lives there using a utility on the Windows side. I have noticed that the permissions on the folders are constantly being changed to Read Only for "Everyone"

 

20100409-fc84fr2h4q7ydcsbmum61tk7g8.preview.jpg

Click for full size - Uploaded with plasq's Skitch

 

Does anyone have a tip or trick that will allow me to force the "Read and Write" attribute on newly created (or it seems even modified) files and folders?

 

Thanks for your help!

Share this post


Link to post
Share on other sites

Dop you have items stored on that drive that you wish to be accessible only from certain users ? If not, I would "get info" on the drive itself and at the bottom of the info window click "ignore permissions on this drive". I'm thinking that would solve your issue.

Share this post


Link to post
Share on other sites

Thanks for the reply.

 

I changed the setting, and it still seems to cause me a problem. It seems that when I creat a new folder on the external drive, it defaults to setting permissions for "Everyone" to Read Only. I have "Shared" selected, and cannot get my Windows box to ignore the default "Read Only" permission. I can try and change the attribute from the windows side, but it immediately reverts back.

 

I will have to go on a search to either tell windows to ignore the permissions, or change the OS X default to Read and Write for Everyone.

 

Any ideas on how to accomplish the latter?

 

Thanks.

 

J

Share this post


Link to post
Share on other sites

The fact that you cannot set the drive to ignore permissions successfully would indicate to me that you have some sort of other system issue. Have you tried repairing permissions and/or running repair disk through Disk Utility ? One other thing I just noticed BTW is that the picture you posted does not show "shared folder" checked ... perhaps that setting is not "taking" either. To change the permission in OS X for that folder, you would click on the padlock in the lower right, enter your Admin password, and then you should be able to simply change the setting where your arrow points to. Then, click the gear box icon and select " apply to all subfolders " ( this will make the current contents of the folder read/write )

Edited by Dolphbucs

Share this post


Link to post
Share on other sites

The drive itself is set as a Share, and I have no issues seeing it over the network. I can change the permissions to Read & Write locally, and they persist.

 

I applyied all of my permissions to subfolders/files, and that worked just fine.

 

The issues seems to be that all new files and folders created on the drive have the "Read Only" attribute set (Whether locally, or from the Windows machine). I was able to set the drive to ignore permissions, but it felt like that was for myself as the user, not for "Everyone"

 

My Googling has led to several posts on other forums about this issue, all without solutions thus far. Apparently TinkerTool was capable of changing the default, but it has been removed in Snow Leopard.

 

The Repair Permissions box is greyed out, I think due to the fact that it is an External drive.

 

Is there a terminal command or script that would accomplish changing all the settings? Admittedly, my Fu in these two areas is weak, and so I have been avoiding this route. It seems that I might be able to work with a script that runs every night, as any files I add are likely to not be modified in that time frame.

 

Is there a way to add my networked Windows machines to a Group in the OS X sharing system? ie get them out of the Everyone classification?

Share this post


Link to post
Share on other sites

You will need to have the windows machine authenticating as a user. You will need to then give that user permission to write to your sharepoint. I think this should just be a case of giving that user read / write access to that folder, but it might require some command line trickery to write the ACL. I've only ever done this on OS X Server, so I would need to dig out the specific terminal commands.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing

    No registered users viewing this page.

  • Who's Online (See full list)

    There are no registered users currently online

×