Jump to content
Sign in to follow this  
James

Mac OS X Mail not deleting GMail?

Recommended Posts

Anyone had any issues with Mac OS X not deleting stuff out of GMail? I keep having spam and junk mail coming back despite it having been marked as spam, moved to spam folder, and erasing spam folder. Similar problem with mail I want to delete from GMail in mail - it just won't die. Both appear to go but if I go back later, it will have resurrected itself. I've even deleted the mail in a browser in Gmail and it appears to have gone from the web based version but I just can't seem to get rid of it inside mail. Anyone got any suggestions? I'm new to Mail, had been using MS Entourage till the start of this week for several years.

 

CYa!

James.

Share this post


Link to post
Share on other sites

I use Gmail through Mail too. I have the same problem too with it - with my Gmail account it for some reason creates a collapsable section that is separate from the main inboxes, with the different sections of my account (Inbox, Sent Mail, Trash, Spam etc) all in there. However, my other TalkTalk email account does not do this for some reason.

With my Gmail account in Mail, I delete the mail out of the inbox. It goes from the web-based version but stays in the duplicated inbox part in the collapsable section for some reason. It's all very confusing.

 

I am sorry I can't help you but I replied just to say that I have the same problem.

 

Here is a screenshot of my Mail window to show the collapsable section which has appeared in the sidebar and won't go away - http://img232.imageshack.us/img232/8278/mailwindow.png

 

 

:)

Share this post


Link to post
Share on other sites

I've got 2 of my Gmail accounts running through Mail as well. I don't know if I can help you with the "not deleting" problem, but there is a way to get some of those extra mailboxes to not show up.

 

Note: This is a Google Labs product so just be warned BUT I've never, ever had this cause a problem.

 

Anyway, to get it set up, sign into Gmail on the web. Then go into your settings and click on the Labs tab. Then find the lab that is called "Advanced IMAP Controls". Enable it and save your changes. Now under you Labels tab in your settings you should see a whole bunch of checkboxes next to all the labels that say "Show in IMAP". Just uncheck any of them you don't want showing up in Mail and you should be all set. The only one I have that shows up in Mail now is my Spam folder, incase it catches the occasional "real" message, but otherwise, my Mail sidebar is now clean!

 

Like I said, this really doesn't help the "not deleting" problem - or at least I don't think it does (maybe this setting is part of the problem...) but hopefully this helps someone out.

 

Apple Geek

Share this post


Link to post
Share on other sites

Sorry to hijack your thread James, but thanks a lot Apple Geek - for me that's what's been annoying me the most. Thanks for pointing that out for me :)

Share this post


Link to post
Share on other sites

I've done some searching and found a few settings you might want to play around with. Go to Gmail in your browser, click on Settings and then the Forwarding and POP/IMAP tab. Under the bottom section are settings pertaining to IMAP. The Auto-Expunge setting is probably the one you want to look at. I have it set to 'Immediately expunge messages when I mark them deleted in IMAP'. This sounds more like what you are looking for.

Hope this helps.

Apple Geek

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing

    No registered users viewing this page.

  • Who's Online (See full list)

    There are no registered users currently online

×