Jump to content
mstamika

Airport Express + Verizon Westell Router + My Book World Edition (Ethernet)

Recommended Posts

My configuration is my Verizon Westell router is plugged into my Airport Express and I get wireless internet through my Airport Express along with being able to stream itunes to my JVC stereo and use my printer.

 

Now I want to throw my Western Digital Network Hard Drive Ethernet into the mix and be able to access it with my Airport Express also.

 

So far I've managed to have it plugged directly into my Westell router but I have to switch back and forth between the Westell connection and the Airport Express connection to be able to access the WD Network Hard Drive Ethernet

 

I bought a Netgear 5 port switcher thinking that would help but it didn't solve the problem or I was missing a key factor which I don't know.

 

Can someone here help me on how to get the WD Network Hard Drive Ethernet to be accessible via Airport Express versus having to switch between network connections, Please?

 

I have a MacBookPro 10.5 running Leopard

Share this post


Link to post
Share on other sites

I think the 5 port switch is the right solution.

 

Your WD hard drive should acquire an IP address when it is connected to the network. Check the documentation for a default IP address, or instructions for setting one.

 

Once you know the IP address, you should be able to connect to the hard drive from the Finder by choosing "Connect to Server" from the Go menu and entering smb://192.168.1.10 (or whatever the hard drives IP address ends up being.

 

Also, Western Digital may have some utility for managing and connecting to the hard drive.

Share this post


Link to post
Share on other sites

I think the 5 port switch is the right solution.

 

Your WD hard drive should acquire an IP address when it is connected to the network. Check the documentation for a default IP address, or instructions for setting one.

 

Once you know the IP address, you should be able to connect to the hard drive from the Finder by choosing "Connect to Server" from the Go menu and entering smb://192.168.1.10 (or whatever the hard drives IP address ends up being.

 

Also, Western Digital may have some utility for managing and connecting to the hard drive.

 

Thank you very much for your reply. Since I am not tech savvy I want to restate what you're suggesting I do so that I'm sure I understand.

 

Connect the switch to the Airport Express (AE) and then plug the router and ethernet hard drive into the netgear switch. Next, look up or set up an IP address for the WD Hard Drive. Once I have the IP address, connect to the hard drive via finder by choosing "connect to server" from the go menu and entering the hard drives IP address.

 

I'll be back in a few hours and let you know what happened.

Share this post


Link to post
Share on other sites

you need to put your Airport Express in Bridge Mode. this allows for wireless devices to see wired devices and vice versa.

 

bridge_mode.png

Edited by johnfoster

Share this post


Link to post
Share on other sites

you need to put your Airport Express in Bridge Mode. this allows for wireless devices to see wired devices and vice versa.

 

bridge_mode.png

 

 

Thank you for your contribution as well AND for the pictures!!! I catch on quick but definitely love step by step instructions and pictures to rule out guessing. Thank you.

I've been hitting refresh for a day and a half waiting for the smart people, knowledgeable to my issue, to arrive :)

 

So my question is what do I do first?

 

1. I connected the switch

2. Located the IP address to my hard drive but haven't tried to connect it yet because I'm wondering what #3 should be in my steps of things to do..

3. ???

 

I'm thinking the next thing I should do is create the bridge in AE bridge? Then do the IP address thing.

 

I'm headed to do that and see what happens.

 

UPDATE: I made it to the "connecting to server" part and got an connection failure message:

Connection failed

The server may not exist or it is not operational at this time. Check the server name or IP address and your network connection and try again.

Then it gave me another error message... The finder cannot complete the operation because some data in smb://my hard disk IP address could not be read or written...

Home Team 0 /Away Team 3

It's working the way is was before, when I click on the Westell Router Network the hard drive pops up in my finder, when I click on the AE network it disappears from the finder.

Edited by mstamika

Share this post


Link to post
Share on other sites

figure out what IP address scheme your network is using. it's either 192.168.x.x or it's 10.10.x.x. it depends on which router is managing the DHCP. you've very likely got a double NAT set up because which is what every noob has with these things. it happens because every network vender wants to make it easier. turning on Bridge mode fixes the double NAT. you might have to turn off DHCP on the Airport.

 

after you know the IP address scheme log into the WD drive and find the part where it lets you enter a fixed IP address. you will have to make it similar to the IP address of your network. but 192.168.1.23 is likely going to work. that or it could be 10.10.1.211. those are two IP addresses on DHCP networks that are usually free AND out of range of the IPs assigned DHCP servers.

 

now turn on Bridge mode and connect your WD drive and Airport to your hub or switch or router. it should work from there.

Edited by johnfoster

Share this post


Link to post
Share on other sites

figure out what IP address scheme your network is using. it's either 192.168.x.x or it's 10.10.x.x. it depends on which router is managing the DHCP. you've very likely got a double NAT set up because which is what every noob has with these things. it happens because every network vender wants to make it easier. turning on Bridge mode fixes the double NAT. you might have to turn off DHCP on the Airport.

 

after you know the IP address scheme log into the WD drive and find the part where it lets you enter a fixed IP address. you will have to make it similar to the IP address of your network. but 192.168.1.23 is likely going to work. that or it could be 10.10.1.211. those are two IP addresses on DHCP networks that are usually free AND out of range of the IPs assigned DHCP servers.

 

now turn on Bridge mode and connect your WD drive and Airport to your hub or switch or router. it should work from there.

 

The IP address scheme is 192.168.x.x

 

How do I turn off the DHCP on the Airport?

And right now everything is plugged in so can you give me a step by step?

 

1. Unplug everything

2. Log in to the WD drive and enter a fixed IP address of 192.168.1.23 (does this mean anyone can hack my network now that they know this info...just wondering)

3. Turn on Bridge Mode (which is currently on since I been messing around with things)

4. Turn off DHCP (not sure how to do this)

5. Plug it all back up and cross my fingers while hitting the on button

 

Sound right?

Share this post


Link to post
Share on other sites

Guess What... :D

Without doing the DHCP thing (which I had no idea how to do)

The drive connected via my AE network

**jumping for joy and high-fiving pwbeninate & johnfoster**

Thank you so much!

 

Soooo... I have to tell you what I did just in case someone stumbles upon this thread with a similar issue.

 

First I had to make sure the drive was empty. I had placed a few files on it when I was doing the switching between networks thing and this was probably one of my first stumbling blocks. The above set up would work best with the drive fresh out the box or with everything moved off of it for setting up.

1. Connect netgear switch (or your choice of switch) to AE, then plug in hard drive ethernet and router into available ports in the swith

2. Go to Applications >Utilities >Airport Utility >Manual Setup >Click On the "Internet" tab along the top

3. Next to "Connection Sharing" select the drop down menu and click on "Off (Bridge Mode)"

4. Click "Update" towards the bottom of the menu

5. Wait for AE to restart (maybe turn your computer on and off :/ Not sure this really helps at this point but hey I was trying everything)

6. Go to Safari Click on the Book like picture in the top corner

7. Click on Bonjour (You should see your hard drive here)

8. Double Click on the drive & follow the set up instructions (my drive is set up with the default DHCP client setting. The device IP address will also be shown here and will allow you to use the "connect to server method above also).

 

Other things I did:

Call my router/wireless internet provider (Verizon) and make sure the drive was showing up. They remoted into my system and poked around and made sure everything was in working order.

Turn my computer on and off :) that fixes everything right

Ask for help when I ran into problems

 

Can't thank you enough, pwbeninate & johnfoster!!! Thank you.

 

Edited by mstamika

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing

    No registered users viewing this page.

  • Who's Online (See full list)

    There are no registered users currently online

×