Jump to content
Sign in to follow this  
FORZA

iTunes library.itl file is locked...help!

Recommended Posts

Not sure how this happened, but when I recently tried to open iTunes and I got this message saying " The iTunes library.itl file is locked, on a locked disk, or you do not have permission for this file". My entire iTunes library resides on an external drive that is connected to my Mac Mini. I recently updated to iTunes 10 when this problem occurred. Any help getting back up and running would be awesome.

Share this post


Link to post
Share on other sites

This happened to me once. A simple re-boot of my machine fixed the problem - with no data loss either. Try that and report back.

Share this post


Link to post
Share on other sites

I have my iTunes library and media in the Shared acct so that I can access iTunes from any of my user accts and that often happens to me when I have had iTunes open in one user acct and then switch to another.

Share this post


Link to post
Share on other sites

This happened to me once. A simple re-boot of my machine fixed the problem - with no data loss either. Try that and report back.

 

No luck on the re-boot. I went into the preferences-advance to see if iTunes was looking at the right folder location and everything was correct.

Share this post


Link to post
Share on other sites

I have my iTunes library and media in the Shared acct so that I can access iTunes from any of my user accts and that often happens to me when I have had iTunes open in one user acct and then switch to another.

 

I did have sharing going on, but I made sure that I closed everything down before viewing the account on my Mac Mini. I am wondering if I should copy the contents of my iTunes folder to a new folder and aim itunes to the new location. However I am bit paranoid in trying this out since I have a ton movies and music that I would be devastated if it were lost somehow. I can't begin tell you how many hours I spent ripping my dvd collection via handbrake.

Share this post


Link to post
Share on other sites

You misunderstood me a little. I don't use Sharing. I just place the entire iTunes folder in the "Shared" user acct ( /users/shared ). I then simply hold down the option key the first time I launch to aim each user to the same iTunes library. I was just saying that I often get the same message if I have two users active and another acct has itunes open while I try to open it in a second acct. I don't think that would be a solution for you however. It sounds to me as though you have a corrupted iTunes library file. I think you may have to rebuild a new library. To do this, merely create a new iunes library ( again by holding down option when you launch iTunes ) in a new "iTunes" folder within your home music folder. This does nothing to your Media. Then, drag your iTunes Media folder into the new "iTunes" folder and point the new iTunes library to the new Media location. Go to File>Add to Library and then select the new media folder location. That will rebuild your library. You might have to replace some album art, but everything else should be fine.

Share this post


Link to post
Share on other sites

You misunderstood me a little. I don't use Sharing. I just place the entire iTunes folder in the "Shared" user acct ( /users/shared ). I then simply hold down the option key the first time I launch to aim each user to the same iTunes library. I was just saying that I often get the same message if I have two users active and another acct has itunes open while I try to open it in a second acct. I don't think that would be a solution for you however. It sounds to me as though you have a corrupted iTunes library file. I think you may have to rebuild a new library. To do this, merely create a new iunes library ( again by holding down option when you launch iTunes ) in a new "iTunes" folder within your home music folder. This does nothing to your Media. Then, drag your iTunes Media folder into the new "iTunes" folder and point the new iTunes library to the new Media location. Go to File>Add to Library and then select the new media folder location. That will rebuild your library. You might have to replace some album art, but everything else should be fine.

 

 

Thanks for the follow up. Yeah I did misunderstand what you were talking about. I will definitely give your suggestion on building a new library a go and report back with the outcome. Thanks again Dolphbucs!

Share this post


Link to post
Share on other sites

Just a quick follow up and thanks to DB and AG for throwing out some suggestions. I tried out your suggestion Dolphbucs and everything seems to be working just like it used to.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing

    No registered users viewing this page.

  • Who's Online (See full list)

    There are no registered users currently online

×