Jump to content
mr.e-man

Windows Server 2008R2 Shares Connect Slowly

Recommended Posts

I'm Mac at heart, but I manage a Windows network for my "real job". I recently moved many of our network file share locations from a Windows Server 2003 server to a 2008 R2 server. I like to create aliases on my Mac for the network locations. The Server 2003 locations used to open up right away. Now, when I connect to Server 2008 R2 shares, there's about a 15 second delay. Windows users have noticed no difference. Has anyone found himself in the same position? Any ideas on a fix?

 

Thanks in advance.

Share this post


Link to post
Share on other sites

Is your Mac bound to AD? Does it resolve to the Windows DNS servers?

 

Here are some DNS tricks that have solved similar issues:

http://www.macwindows.com/snowleopard-filesharing.html#070810a

 

Also make sure your Workgroup name in System Preferences -> Network -> Advanced -> WINS matches your AD domain name or Windows workgroup.

Share this post


Link to post
Share on other sites

Thanks for the reply. It has (at the very least) started me on a wild goose chase for an answer.

 

My WINS settings were not set to my local AD name. I made that change but it didn't seem to speed things up too much. I'm now pursuing the DNS route. Let me know if you're at all interested in the results of my findings and I can post them back here. Otherwise, thanks for the help.

Share this post


Link to post
Share on other sites

Sure, definitely post your findings here. You may be able to save someone pain in the future :)

Share this post


Link to post
Share on other sites

Yup, I'd say it sounds like your dns isn't perfect somewhere. Looking forward to hearing your results (although thankfully I have very little to do with windows servers nowadays).

Share this post


Link to post
Share on other sites

I have not had much of a chance to dive in to a lot of DNS stuff, but I did make one change that seems to have sped up the connection process with the Windows Server 2008R2 shares.

 

Under: Sys Pref --> Accounts --> Login Options ... I set the "network account server" to my local Active Directory domain.

 

Seems to have helped at least a little.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing

    No registered users viewing this page.

  • Who's Online (See full list)

    There are no registered users currently online

×