Jump to content
kevanp

Safari not downloading

Recommended Posts

Safari is exhibiting weird behaviour on my wife's computer – and a bunch of other people's too, judging from the Apple support community. When she clicks a link to download something (a PDF, for example, or a DMG) she gets the progress indicator in the address bar, showing that something is happening, and then a black Safari window at the end of the process, but with nothing actually having downloaded.

 

She is using my old MacBook Pro (17" 2.16 GHz Intel Core Duo), with OS X 10.6.8, and Safari 5.1.2. I have the identical operating system and Safari versions, but have no problem! The only difference is that my MacBook Pro is a 17" 2.66 GHz Intel Core i7.

 

Someone elsewhere has suggested opening Safari in 32-bit mode. But when I 'Get Info' on the app on my wife's computer, there is no "Open in 32-bit mode" check box. When I do the same on my computer, you guessed it, there is a check box (though I haven't had to check it).

 

Can anyone please throw any light on the problem? Oh, forgot to mention that I have tried:

 

1. Discarding the preference files, and the entire Safari folder in the ~/Library folder

 

2. Booting into a different user

 

3. Re-downloading and re-installing the Safari app.

 

None of this has made any difference.

 

All plausible suggestions welcome!

 

Thanks, Kevan

 

Edited by kevanp

Share this post


Link to post
Share on other sites

from: https://discussions.apple.com/thread/2140662?start=0&tstart=0

 

The problem was that a "Speed Download Plugin" was interferring with the Safari download capability. (In case you've installed Speed Download, if not then some other plugin is interfering, to find out which plugins are installed go to Safari Help -> Installed Plugins and check for those plugins that have associated with general files like dmg, zip etc..).

 

To remove the Speed Download plugin go to /Library/Internet Plugins/ and remove the Speed Download plugin and restart Safari! Enjoy!

or if that is the problem:

delete the file located in Macintosh HD/Library/Internet Plug-Ins/PDF Browser Plugin.plugin and re-launched Safari again.

if that doesn't work drag all the files out of the Internet Plug-Ins folder to a different folder. delete the originals. then restart.

Share this post


Link to post
Share on other sites

John

 

Good call. Many thanks. Speed Download wasn't installed (I'd already removed it and all its associated files). However PDF Browser Plugin and AdobePDFViewer were in the Internet Plug-Ins folder. I removed these, and PDFs now behave: they open in Safari, and they can be saved from there to wherever you choose.

 

And I've just fathomed why there's no 'Open in 32-bit mode' check-box for the Safari app: my wife's computer has an Intel Core Duo CPU, not Core 2 Duo. So it cannot operate in 64-bit mode.

 

Cheers

 

Kevan

 

 

 

 

Edited by kevanp

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing

    No registered users viewing this page.

  • Who's Online (See full list)

    There are no registered users currently online

×