Jump to content
Sign in to follow this  

mounting an nfs share under tiger

Recommended Posts

I have a linux box and I have set up an NSF export. When I try to mount this under os x, I get the error "operation not permitted" even though I am running the mount command with sudo. Has anyone gotten this to work ? If so what do I have to do ?




Share this post

Link to post
Share on other sites

Hello Leigh.


You've probably already found a solution by now, or given up. But in case you haven't, I recommend that you use the system services to do a mount as a regular user (by doing a Go->Connect to Server... via Finder). I've found that to work much better than trying to do a `mount_nfs -o such,and,such svr:/share/path /mnt/path` as root.


Also, there is a great program called NFS Manager that I've used with good results.


On the Linux side of things, make sure your /etc/exports is configured correctly and watch the system log for rpc.* and portmap errors. Personally, I find it easiest to configure the Linux server with nailed user and group IDs, since they're not consistent in my network:


# /etc/exports



It's my understanding that user-initiated NFS mounts in Mac OS X by default use ports above 1024, therefore the "insecure" option is needed on the share. However, that hardly makes NFS any less secure than it was already. If you want to require the mount to use a low port, use NFS Manager. I believe it has the option to do that.


Good luck.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing

    No registered users viewing this page.

  • Who's Online (See full list)

    There are no registered users currently online