Jump to content
Sign in to follow this  
jlamoree

BitTorrent clients hang after a couple days

Recommended Posts

I've tried the popular BitTorrent clients (Azureus 2.3.x, Tomato Torrent 1.1.2, BitTorrent 4.1.2) and they all seem to exhibit the same symptom after operating for more than a couple days. On several Mac OS X Tiger machines on which I've tried, these clients work perfectly for a while, and then become unresponsive and eventually bring the system to its knees. On my primary workstation, I've got 2.5 Gb of RAM on a Dual G5, and yet the system loses its ability to create new windows or close applications. The beach ball just spins forever.

 

Does this sound familiar to anybody?

 

I've done a considerable amount of troubleshooting so far. Watching the log files, examining the CPU load, logging in from a different machine over SSH and monitoring the system. I just can't seem to find a reasonable explanation for the problem.

 

I thought maybe it was because putting my machine on the network and sharing up files made it more visible to Script Kiddies. I'm not aware of any attacks that my machines would be susceptible to. All my other machines have no problem uploading/downloading of the same line. I've tried connecting my behind and in front of the NAT machine.

 

It's possible, I suppose, that there is some kind of file handle limit that exists when the clients are chunking up the data into little pieces and doing reads and writes at random seeks. But that just doesn't seem plausible, considering that none of my other applications have any sort of similar issue, and it happens nearly the same way on multiple machines, each with wildly different Apple hardware.

 

If anybody has any thoughts, please shout them out.

Share this post


Link to post
Share on other sites

Reapair permissions, and are you downloading the same thing on all machines ?

Share this post


Link to post
Share on other sites

The permissions are correct, as far as Disk Utility 10.5.1 (198.1) is concerned. I typically install applications into ~/Applications, rather than /Applications -- I want to keep the system as pristine as possible. This also makes it easy for me to create a new user account for testing purposes. The owner and group of the files in ~/Applications are all appropriate for the user's account, and the file modes are reasonable. The destination for the torrent data is a directory inside $HOME on the system disk. Nothing complicated like external, removable disks -- just one disk, with one system volume with the Apple partition scheme.

 

Azureus works incredibly well for many hours. I can watch the console messages fly by without seeing any noticeable errors.

 

No other significant applications are running. There are little things like QuickSilver, MenuMeters, Little Snitch, Stuffit MagicMenu, and so forth. But it doesn't seem to make a different whether they're running or not.

 

The actual torrent content that I'm attempting to download/upload differs. Sometimes it's music, sometimes is TV shows, sometimes it's a new Linux distro. I can't find any particular pattern to the behavior.

 

I saw suggestions out there about reducing the number of download/upload slots in Azureus to avoid running out of memory and/or crashing. I decreased the slots to just 1, but it doesn't seem to make a difference -- eventually the entire system becomes unresponsive. And I'm talking like *really* unresponsive. The NIC doesn't even echo back a ping. However, the window server is running, and I can drag windows around the screen. I can do the Command+Option+Escape dance and try to kill things off, but it usually doesn't work.

 

In my gut, I have a feeling that this is some sort of wacky windowing system bug from the legacy NeXTSTEP codebase. The fact that Azureus does its voodoo with Java and the other clients use Python boggles my mind. A reasonable person wouldn't think that the same problem would be caused by programs using such different frameworks and languages.

 

I set up a test this evening on a super-clean Mac OS X Tiger workstation that isn't doing anything else. I've got a Apple Remote Desktop view open so I can see Azureus in action with a couple torrents. I've got a SSH console open with `nice top -n 20 -o cpu -s 5` running. Let's see how long this lasts...

Share this post


Link to post
Share on other sites

I read your post and it sounds as though you are very experienced in using the Mac and Bit Torrent. I apologize in advance for an extreme novice question, but would appreciate any suggestions. I have a 17" 1.33 GHz PowerBook G4 w/1.5 GB of RAM running Mac OSX 10.4.2. I also have a DSL broadband connection with wireless access provided by my Airport Express. I'm pretty good with basic software, podcasts (like Adam's), iTunes, etc. but certainly a simple everyday user with limited technical knowledge.

 

I keep hearing about Bit Torrent on various podcasts, etc. and am interested in using it. However, when I run a Google search and locate various websites that discuss Bit Torrent (like Wikipedia) and try and learn about how to use it, I only meet with frustration? Can you suggest a weblink/site that provides a simple 1-2-3 step explanation of how to use Bit Torrent for someone like me? What software do I need to download? Any special instructions for installing it? Basics of using it once it's installed? How to find files to download once I have the software installed?

 

Any help would be greatly appreciated! There's lots of info out there, but its all pretty technical as best I can tell. At this point, I'm beginning to think perhaps its a little beyond my capabilities.

 

LRL

Share this post


Link to post
Share on other sites

Hello LRL.

 

There are two major types of P2P networks/protocols: Gnutella and BitTorrent. These are very different animals, and I use each for a different purpose.

 

When I'm interested in finding a particular file with a known name, I use AcquisitionX to search the Gnutella network. Limewire is another good client, but without the attention to Apple user interface guidelines.

 

When I'm looking for complete albums, or very large batches of files, I use BitTorrent.

In my previous post, you saw a list of BitTorrent clients that I have used. By far, Azureus, is the best BitTorrent client. I do a considerable amount of Java programming, and when I look at what the Azureus developers have done, I am humbled.

 

The challenge with using BitTorrent is that the user must find a source for active torrents. I like MiniNova right now. Unfortunately, good BitTorrent sites come and go. Good torrent sites categorize the data so you can quickly find all the episodes of a particular TV show, for example, regardless of the actual filename of the video file.

 

Hope that helps.

Share this post


Link to post
Share on other sites

So, in my previous posts, I was fairly confident that I could reproduce the problem I reported. Of course, now that I've publicly asserted that the problem exists, I can't reproduce it.

 

In my first test, I started with Azureus and a humble number of torrents. It ran just fine for a while, until Southern California Edison interrupted my test. The next time I booted it up, I added quite a few torrents, trying to push up the limits. It's still running. I'm sure I could force it to die by increasing the number of slots to unlimited and filling it with dozens of torrents. But my purpose was really to find the cause of a problem under normal use. Arg.

 

At the moment, it's running fine:

$ uptime

8:50  up 5 days,  2:34, 3 users, load averages: 1.05 0.79 0.79

 

Sure, the java_swt process is putting a fair amount of load on the CPU, but it's still doing it's job correctly.

 

If I get any new information, I'll post again.

Share this post


Link to post
Share on other sites

I tried Azureus and found it was a bit of a "hog the box", but it never got to the point where it was unresponsive.

 

You obviously know what you're doing. My first thought was log files, or third party apps, but you've checked these.

 

I'm currently using Transmission, been running several days no problems.

http://transmission.m0k.org/

 

Transmission is written in C, maybe that'll make a difference!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing

    No registered users viewing this page.

  • Who's Online (See full list)

    There are no registered users currently online

×