Jump to content
Sign in to follow this  
Bigpics

Still can't network Mac to on main PC

Recommended Posts

:evil:

 

It's like Emily Latella says, "if it's not one thing, it's another."

 

I have one iBook I take with me when "commuting" between my residences in NY and out West where each home has a PC tower and wireless router. I was never able to get the iBook to print through the NY PC into my Pixma i4000 and eventually just started to plug into the printer I want to print to. But I WAS able to network the two computers and share files in both directions.

 

I'm now out west with setup #2 and my new Canon Pixma i5200r has given me wireless printing from my iBook while the PC's plugged into its USB port -- so both computers print to the Pixma independently and only either computer has to be turned on. Yaaay!!! I'll implement the same solution when I get back to NY.

 

But this brings me to my CURRENT problem..... (in my continuing switcher/multi-OS saga):

 

As noted, I mastered sharing files between my ibook and my NY PC -- however, I haven't been able at all to do the same thing with the same iBook with my PC out West.

 

My iBook just can't see my PC files (with all sharing enabled on both machines) -- it sees the Network and the workgroup NAMES but doesn't mount or see any shared folders.

 

And from the PC side, Explorer takes about 3 minutes when I click on the Network name or on workgroup and then just either gives up or crashes the Explorer window.

 

I've been through everything I did back in NY (I think) numerous times, but nada.

 

Any suggestions??

Share this post


Link to post
Share on other sites

I believe to have posted this reply just yesterday and it seems to have disappeared - so I'm posting it again:

 

What OSes are you using on the PCs? Is the setup identical (or at least similar) in both locations?

Share this post


Link to post
Share on other sites

I am connecting my PowerBook and my PowerMac G4 to some of my Windows machines on a regular base...

So when the Explorer on the Wintel machine crashes when you try to browse the Network there seems to be a problem with XP's Network settings.

 

Try to disable Networking, check all settings and reenable the Network setting on the Windows side...

 

Are all the basic settings correct (IP Range, Network Mask etc....)

I sometimes have the almost working Settings on my windows machines and while troubleshooting I realise a very basic setting as beeing wrong (given the same IP to 2 different machines, having used a wrong network mask etc...)

 

Hope I could give some inspiration

Share this post


Link to post
Share on other sites
I believe to have posted this reply just yesterday and it seems to have disappeared - so I'm posting it again:

 

What OSes are you using on the PCs? Is the setup identical (or at least similar) in both locations?

 

The PC that DOES connect to the iBook (10.4.3) is a custom box (from ABS) running XP Pro with all latest updates -- It's also running the free Kerio Firewall and free AVG A/V software.

 

The PC that WON'T connect is an HP running XP Home with all latest updates. It's also running the Symantec suite of Firewall and Norton A/V protection. I thought this might be part of the problem, but the firewall so dislikes being disabled it puts up a message about how unhappy it is every 10 seconds or so and I haven't figured out how to really turn it "off off." (I did find out my relatives had enabled both the Win and Symantec firewalls and turned off the Win firewall, but no help.)

 

Maybe I need to try keeping Symantec from starting up in MSCONFIG (with the broadband disconnected)?? Still, it's never popped up a message telling me a device is trying to get through the firewall either......

 

What I also don't understand is how the iBook can see the network name on the PC (and I know it's the right network because I renamed it and the new name shows up) but can't see any of the files for which sharing has been enabled (and I know they're shared, because the sharing hand icon appears on those folders).

 

Just to reiterate, WinExplorer sees nothing or just stops when I click on the (renamed) MSHOME or Workgroup icons on the Network section.

 

There was also a stage in networking the two computers in NY where I was asked to sign into the mac with my mac password and on the mac where I recall having to give an address of some sort with some double forward slashes, but neither of these screens have ever come up on either computer in my attempts to network out west.

 

I also tried connecting the Mac directly to the router by ethernet to no avail.

Share this post


Link to post
Share on other sites

As far as I know the main difference between XP Home and Professional are Home's crippled Nerwork capabilities...

I can't remember it exactly, but before I switched to Mac OS X almost 2 years ago I had some of your troubles with my Windows Boxes.

So I upgraded all my Systems in my Network to XP Professional before.

 

When trying to connect different Windows Versions they often did not see each other, mainly because the LM-Searching was not enabled (and the setting is in every Windows Version hidden in another corner)!

The next Problem I remember is due to "simple sharing" (freely translated from the german Windows XP Version).

I am not shure if you can deselect that in XP Home, but when I switch it off on my Professional Boxes Sharing and granting user access for folders has some more advanced features.

 

The boxes for the double slashes something you can get on the Mac with the Finder Menu GOTO - CONNECT TO SERVER or the Shortcut [APPLE]+[K]

and on Windows in the Explorer EXTRAS - Connect to Networkshare or Networkdrive.

 

Hope that helps a little

 

By the way, have you already checked if the Mac can ping the Windows Box and vice versa???

Share this post


Link to post
Share on other sites

First of all: I can confirm what macSibbern wrote concerning XP Home's network 'capabilities' - it's very rudimentary (at best) compared to Professional. At any rate, since performing remote analyses is somewhat difficult let me just give you a few things you could try:

 

On the Windows machine, open (or create) a file named "hosts" (no extension) in c:windowssystem32driversetc.

In there, add a line giving the IP address of your iBook followed by a tab followed by the hostname that you have configured for your iBook (you can see the hostname by selecting 'Sharing' in System Preferences)

 

The line should just read

 

192.168.0.1<tab>ibookhostname

 

replacing 192.168.0.1 by the iBook's IP address, <tab> by pressing the tab key and ibookhostname by the hostname. Make sure you press 'Enter' after the hostname so you add an empty new line below.

Just to make sure you should restart windows and then (with the iBook running and connected) start up a command window by pressing Windows+R and entering 'cmd'.

In there enter 'ping ibookhostname' where ibookhostname should again be substituted as above.

 

If you receive any replies this is good, your PC seems to be able to contact your iBook.

 

You should now ensure that the workgroup name is identical on both the iBook and the PC. On the PC you can find out the workgroup name by selecting 'System' in the control panel and there selecting the 'computer name' (or similar) tab. Probably you won't be able to change that name in XP Home, so you'll have to change it on the iBook if it differs. In order to do that, open /Applications/Utilities/Directory Access. In that application, select SMB/CIFS and click 'configure'. Set the workgroup accordingly.

You may have to restart the iBook, I'd do - just to be sure.

 

Now back to the PC.

Close the Command window and once again press Windows+R but this time enter ibookhostnamesharename (once again substitute ibookhostname with the hostname and sharename with the name of the share you set up in OSX (usually this will be your short username; you can see the proper share name by selecting 'Windows Sharing' from the 'Sharing' preference pane in System Preferences).

 

If this doesn't work, you'll probably have to figure out how to uninstall Symantec's firewall. If I remember correctly the uninstaller is somewhere in C:Program FilesSymantec* and has a very misleading name so keep searching.

 

Hope this helps!

 

-Christian

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing

    No registered users viewing this page.

  • Who's Online (See full list)

    There are no registered users currently online

×