Jump to content
theOlster

Apche, PHP & MySQL HowTo

Recommended Posts

Hi guys...

 

As a recent switcher (just over 24hrs now) from Linux and Windoze, I am quite keen to find out how to install Apache, PHP and MySQL on my iBook. This would be particularly helpful for using Dreamweaver.

 

Does anyone know where I can find step-by-step instructions for installing these..?

 

Many thanks.

Share this post


Link to post
Share on other sites

Apache is already installed on your Mac. You just need to turn it on. You also need to turn on websharing in your Sharing preference panel.

 

See Marc Liyange's website for mysql and php packages and basic instructions. If you need more user friendly documentation about configuration and all on the Mac, see the MacZealot's Wordpress tutorial on installing mysql/php and starting Apache.

 

There's more Mac friendly sites out there. Try a google search for php and Mac. I believe there's a php on the Mac user group forum, but don't have a link bookmarked.

Share this post


Link to post
Share on other sites

I second using Marc Liyange's web site. That is how I figured it out. If you have specific questions you are welcome to email me.

Share this post


Link to post
Share on other sites

If you are looking for more recent versions of Apache, MySQL and PHP (and more) you might also check http://www.mamp.info/ which is essentially a single package/program which gives you all three with pretty much zero effort on your part. And yes, you can still edit config files and all that if you want specific settings.

Share this post


Link to post
Share on other sites

Hi Guys, I know its a while since I posted the questions, but I just thought I'd let you know that the PHP & MySQL install went perfectly. I ended up using Marc Liyange's installation guides which were a peice of cake to use.

 

Thanks for the help!

Share this post


Link to post
Share on other sites

I don't know about firevault. perhaps someone else will.

 

Here's a few things to check. Have you checked your firewall settings? Did you re-write your htacess file? Is personal web sharing still on? Did you change the permissions on your /Users/yourname/Sites folder? Can you access the sites folder in another user (with pws on)?

 

If you can access the localhost but not the sites folder in your user then something sounds glitched in the home folder.

 

I'm just an amateur, so hopefully someone more knowledgeable will come along with more info.

 

good luck.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing

    No registered users viewing this page.

  • Who's Online (See full list)

    There are no registered users currently online

×